summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Sanches2022-01-24 11:41:17 -0300
committerGabriel Sanches2022-01-24 11:41:17 -0300
commita4784832f9015fc45feb92576d039547b825020c (patch)
tree1ae7d069255945b093f1fb1997a43c467651318a
parent56601cb0bce881b97e9d19ac4a1410e3696cd83b (diff)
downloadaur-a4784832f9015fc45feb92576d039547b825020c.tar.gz
Add prepare stage so frozen build doesn't break
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2db183f137e8..1715b7d8edea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = park
pkgdesc = Configuration-based dotfiles manager
pkgver = 0.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/gbrlsnchs/park
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 3d848e64268c..51e49d0b4ed2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
pkgname=park
pkgver=0.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Configuration-based dotfiles manager"
url="https://gitlab.com/gbrlsnchs/park"
source=("https://gitlab.com/gbrlsnchs/park/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
@@ -15,6 +15,10 @@ optdepends=(
sha256sums=("4ac2c12f7d063b1614d3e767942daea05765593566e102939976d267950f546a")
+prepare() {
+ cargo fetch --locked --target "$ARCH-unknown-linux-gnu"
+}
+
build () {
cd "${srcdir}/${pkgname}-v${pkgver}"