summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Ruijl2015-06-13 15:20:16 +0200
committerBen Ruijl2015-06-13 15:20:16 +0200
commit0242078495fc5e11cc7cc1651ad15503621c229d (patch)
tree831e37e73d8b9aefaff0a4f18399b2cb0132b149
downloadaur-parlance.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff0384af061d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = parlance
+ pkgdesc = A framework for playing the Diplomacy board game over a network
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/Parlance
+ arch = any
+ license = Artistic License 2.0
+ depends = python2
+ source = https://pypi.python.org/packages/source/P/Parlance/Parlance-1.4.1.tar.gz
+ md5sums = c6e79a31cd9bb7ecdc3f8142712a9daf
+
+pkgname = parlance
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6902cd186b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=parlance
+_pkgname=Parlance
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="A framework for playing the Diplomacy board game over a network"
+url="http://pypi.python.org/pypi/Parlance"
+arch=("any")
+license=("Artistic License 2.0")
+depends=("python2")
+source=("https://pypi.python.org/packages/source/P/Parlance/Parlance-1.4.1.tar.gz")
+md5sums=('c6e79a31cd9bb7ecdc3f8142712a9daf')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ find . -type f -exec sed -i 's/env python/env python2/g' {} \;
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}