summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Hayot2017-07-05 10:27:11 +0200
committerGuillaume Hayot2017-07-05 10:27:11 +0200
commit0ed4824f2dfc8d130197801b6ba6b1bf6885cb8f (patch)
treefa06c4cf93d97ba560a5cc942aff3dd504d6ebbf
parent03d0354ed5de6ad4b9296614569d4d832a79e59b (diff)
downloadaur-0ed4824f2dfc8d130197801b6ba6b1bf6885cb8f.tar.gz
Reworked dependencies
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90fccbe86a7c..fa9950abf20f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=parlatype
pkgver=1.5
-pkgrel=3
+pkgrel=4
pkgdesc="GNOME audio player for transcription"
arch=('any')
url="https://gkarsay.github.io/parlatype/"
license=('GPL')
-depends=('gtk3' 'intltool' 'gobject-introspection' 'yelp-tools' 'gst-plugins-base' 'gst-plugins-good' 'libreoffice')
+depends=('gtk3' 'gst-plugins-base' 'gst-plugins-good')
+makedepends=('gobject-introspection' 'libreoffice' 'yelp-tools' 'intltool' 'glade' 'gtk-doc')
+optdepends==('libreoffice: LibreOffice macros')
source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
noextract=()
md5sums=('8de6ae7bb0f261b4f48effbe133684c5')
@@ -18,7 +20,14 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
autoreconf
- ./configure --prefix=/usr --disable-introspection
+ # Parlatype ships its own library, libparlatype. Developers might be interested in having a library documentation,
+ # gobject introspection and a glade catalog for the widgets. These are the configure options:
+ # --enable-gtk-doc: install library documentation (default: no)
+ # --enable-introspection: install gobject introspection (default: yes)
+ # --enable-glade-catalog: install a glade catalog (default: no)
+ # --with-libreoffice: install LibreOffice macros (default: yes)
+ # If you want the program only, you would use --prefix=/usr --disable-introspection.
+ ./configure --prefix=/usr --enable-gtk-doc --enable-glade-catalog
make
}