summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Hayot2019-05-24 08:53:45 +0200
committerGuillaume Hayot2019-05-24 08:53:45 +0200
commitc10b56159b1774e5a6ceec9637106bf2b5f005e4 (patch)
treed4c346099665fcb2a0b620ab1c909693b4c7d243
parent6bd864fc79d01a38050d6b2683cc02b7b37f322c (diff)
downloadaur-c10b56159b1774e5a6ceec9637106bf2b5f005e4.tar.gz
Bump to 1.6
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 16 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bbcaaa0352f..f501b96e8b2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = parlatype
pkgdesc = GNOME audio player for transcription
- pkgver = 1.5.6
+ pkgver = 1.6
pkgrel = 1
url = https://gkarsay.github.io/parlatype/
arch = any
license = GPL
makedepends = libreoffice
+ makedepends = meson
+ makedepends = appstream
makedepends = yelp-tools
- makedepends = intltool
- makedepends = gobject-introspection
+ makedepends = python-atspi
+ makedepends = sphinxbase
+ makedepends = pocketsphinx
depends = gtk3
depends = gst-plugins-base
depends = gst-plugins-good
optdepends = libreoffice: LibreOffice macros
optdepends = gst-plugins-ugly: Play MP3 files
- source = https://github.com/gkarsay/parlatype/releases/download/v1.5.6/parlatype-1.5.6.tar.gz
- sha256sums = ae72ac7c80e1adfec8b0f04bec066e2c45adf0da90736707a5f962cfdd722f3f
+ source = https://github.com/gkarsay/parlatype/releases/download/v1.6/parlatype-1.6.tar.gz
+ sha256sums = 8150aab04988b6966863f8c42fbab7a8d096b52c859929a819b19ef307f878b9
pkgname = parlatype
diff --git a/PKGBUILD b/PKGBUILD
index 568a4201e2ee..ea9b26065417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,25 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=parlatype
-pkgver=1.5.6
+pkgver=1.6
pkgrel=1
pkgdesc="GNOME audio player for transcription"
arch=('any')
url="https://gkarsay.github.io/parlatype/"
license=('GPL')
depends=('gtk3' 'gst-plugins-base' 'gst-plugins-good')
-makedepends=('libreoffice' 'yelp-tools' 'intltool' 'gobject-introspection')
-# makedepends=('libreoffice' 'yelp-tools' 'intltool' 'gobject-introspection' 'glade' 'gtk-doc')
+makedepends=('libreoffice' 'meson' 'appstream' 'yelp-tools' 'python-atspi' 'sphinxbase' 'pocketsphinx')
optdepends=('libreoffice: LibreOffice macros' 'gst-plugins-ugly: Play MP3 files')
source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('ae72ac7c80e1adfec8b0f04bec066e2c45adf0da90736707a5f962cfdd722f3f')
-
-prepare() {
- cd "$pkgname-$pkgver"
-}
+sha256sums=('8150aab04988b6966863f8c42fbab7a8d096b52c859929a819b19ef307f878b9')
build() {
cd "$pkgname-$pkgver"
- autoreconf
- # Parlatype ships its own library, libparlatype.
- # Developers might be interested in having a library documentation, gobject introspection
- # and a glade catalog for the widgets.
- # These are the configure options:
- # --with-libreoffice: install LibreOffice macros (default: yes)
- # --enable-introspection: install gobject introspection (default: yes)
- # --enable-tests: build unit tests (default: yes)
- # --enable-gtk-doc: install library documentation (default: no)
- # --enable-glade-catalog: install a glade catalog (default: no)
- # --enable-code-coverage: enable gcov/lcov code coverage (default: no)
- # If you want the program only, you would use --prefix=/usr --disable-introspection.
- ./configure --prefix=/usr --disable-introspection --disable-tests
- make
-}
-
-check() {
- cd "$pkgname-$pkgver"
- make -k check
+ meson build --prefix=/usr
+ cd build
+ ninja
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"/build
+ DESTDIR="$pkgdir/" ninja install
}