summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-06-22 14:54:53 -0400
committerGuillaume Horel2017-06-22 14:54:53 -0400
commit19f00a5f379a72dedcfba3f51f0fdd6cc0a3cf96 (patch)
tree95567b05e481b7318c2c9b5b1ffedcff901c7cca
parenta22d278ecb99b1da51c127b344643bc08594891c (diff)
downloadaur-19f00a5f379a72dedcfba3f51f0fdd6cc0a3cf96.tar.gz
version bump
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd673e6015a4..ff1604dcc426 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = parquet-cpp
pkgdesc = A C++ library to read and write the Apache Parquet columnar data format.
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://arrow.apache.org
arch = i686
arch = x86_64
license = Apache
+ makedepends = boost
makedepends = brotli
makedepends = cmake
+ makedepends = git
makedepends = snappy-static
makedepends = thrift-static
- makedepends = boost
depends = gcc-libs
depends = boost-libs
depends = arrow
- source = https://github.com/apache/parquet-cpp/archive/apache-parquet-cpp-1.1.0.tar.gz
- sha256sums = 7fb059900c313a5cbc6990ba5405df6076dd5f78d5430cfcb2d19d5d5f4043df
+ source = git+https://github.com/apache/parquet-cpp.git#commit=ce5e1e7dd6799df5411148479f0eb2626e3fff72
+ sha256sums = SKIP
pkgname = parquet-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 7aae5bf1bb5b..d0e46fd7be5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=parquet-cpp
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A C++ library to read and write the Apache Parquet columnar data format."
arch=('i686' 'x86_64')
url="https://arrow.apache.org"
@@ -10,12 +10,12 @@ license=('Apache')
depends=('gcc-libs' 'boost-libs' 'arrow')
checkdepends=()
optdepends=()
-makedepends=('brotli' 'cmake' 'snappy-static' 'thrift-static' 'boost')
-source=("https://github.com/apache/parquet-cpp/archive/apache-$pkgname-$pkgver.tar.gz")
-sha256sums=('7fb059900c313a5cbc6990ba5405df6076dd5f78d5430cfcb2d19d5d5f4043df')
+makedepends=('boost' 'brotli' 'cmake' 'git' 'snappy-static' 'thrift-static')
+source=("git+https://github.com/apache/parquet-cpp.git#commit=ce5e1e7dd6799df5411148479f0eb2626e3fff72")
+sha256sums=('SKIP')
build(){
- cd "$srcdir/$pkgname-apache-$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
mkdir -p build
cd build
PARQUET_BUILD_TOOLCHAIN=/usr cmake .. \
@@ -23,7 +23,6 @@ build(){
-DPARQUET_BUILD_TESTS=off \
-DPARQUET_BUILD_EXECUTABLES=off \
-DPARQUET_BUILD_BENCHMARKS=off \
- -DPARQUET_ARROW=on \
-DPARQUET_USE_SSE=on \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib"
@@ -31,7 +30,7 @@ build(){
}
package(){
- cd "$srcdir/$pkgname-apache-$pkgname-$pkgver/build"
+ cd "$srcdir/$pkgname/build"
make DESTDIR="${pkgdir}" install
}