summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-31 13:04:19 -0400
committerGuillaume Horel2017-07-31 13:04:19 -0400
commit958f6735386e3cfa9bcfa79c15568e34b2994df9 (patch)
treec0341691a13e3e6135fbedb219b45b1842eb883c
parentc5457b30ff9cf4bcb96dc06ecb702120a635c238 (diff)
downloadaur-958f6735386e3cfa9bcfa79c15568e34b2994df9.tar.gz
version bump
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85379d27330f..65e9234e8e78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = parquet-cpp
pkgdesc = A C++ library to read and write the Apache Parquet columnar data format.
- pkgver = 1.1.0
- pkgrel = 2
+ pkgver = 1.2.0_rc1
+ pkgrel = 1
url = https://arrow.apache.org
arch = i686
arch = x86_64
@@ -9,14 +9,12 @@ pkgbase = parquet-cpp
makedepends = boost
makedepends = cmake
makedepends = git
- makedepends = snappy-static
makedepends = thrift-static
- depends = gcc-libs
- depends = brotli
- depends = boost-libs
depends = arrow
- source = git+https://github.com/apache/parquet-cpp.git#commit=ce5e1e7dd6799df5411148479f0eb2626e3fff72
- sha256sums = SKIP
+ depends = boost-libs
+ depends = gcc-libs
+ source = https://github.com/apache/parquet-cpp/archive/apache-parquet-cpp-1.2.0-rc1.tar.gz
+ sha256sums = d68268c07c2caeb347be4386c3e7c4c26add3816412f607c6b254fea9e2a0f2d
pkgname = parquet-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 81b0a572b8ec..b9305034d4d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=parquet-cpp
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.2.0_rc1
+pkgrel=1
pkgdesc="A C++ library to read and write the Apache Parquet columnar data format."
arch=('i686' 'x86_64')
url="https://arrow.apache.org"
license=('Apache')
-depends=('gcc-libs' 'brotli' 'boost-libs' 'arrow')
+depends=('arrow' 'boost-libs' 'gcc-libs')
checkdepends=()
optdepends=()
-makedepends=('boost' 'cmake' 'git' 'snappy-static' 'thrift-static')
-source=("git+https://github.com/apache/parquet-cpp.git#commit=ce5e1e7dd6799df5411148479f0eb2626e3fff72")
-sha256sums=('SKIP')
+makedepends=('boost' 'cmake' 'git' 'thrift-static')
+source=("https://github.com/apache/parquet-cpp/archive/apache-parquet-cpp-${pkgver/_/-}.tar.gz")
+sha256sums=('d68268c07c2caeb347be4386c3e7c4c26add3816412f607c6b254fea9e2a0f2d')
build(){
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-apache-$pkgname-${pkgver/_/-}"
mkdir -p build
cd build
PARQUET_BUILD_TOOLCHAIN=/usr cmake .. \
@@ -30,12 +30,12 @@ build(){
}
package(){
- cd "$srcdir/$pkgname/build"
+ cd "$srcdir/$pkgname-apache-$pkgname-${pkgver/_/-}/build"
make DESTDIR="${pkgdir}" install
}
#check(){
-# cd "$srcdir/$pkgname-apache-$pkgname-$pkgver/build"
+# cd "$srcdir/$pkgname-apache-$pkgname-${pkgver/_/-}/build"
# make test
#}
# vim:ts=2:sw=2:et: