summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordelta482015-06-08 14:07:19 -0500
committerdelta482015-06-08 14:07:19 -0500
commit6b81354c00b45f5da4b125ef87e7aece836a2c6d (patch)
treef93f2f079f641ccf01e7fe8fef11b54fd0346de3
downloadaur-6b81354c00b45f5da4b125ef87e7aece836a2c6d.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD53
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccded477daab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = parsec47
+ pkgdesc = Fast-paced retro shoot'em up in an abstract world
+ pkgver = 0.2
+ pkgrel = 2
+ url = http://www.asahi-net.or.jp/~cs8k-cyu/windows/p47_e.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gdc
+ depends = sdl_mixer
+ depends = libbulletml
+ source = http://abagames.sakura.ne.jp/windows/p47_0_2.zip
+ source = http://ftp.de.debian.org/debian/pool/main/p/parsec47/parsec47_0.2.dfsg1-6.debian.tar.gz
+ md5sums = 9d90057a269591fe992b7ed44de2d29f
+ md5sums = 98d19456f1bf69709b20dbf9fd175ab5
+
+pkgname = parsec47
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edcbcf41d192
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: megadriver <megadriver at gmx dot com>
+# Shamelessly ripped off from the a7xpg PKGBUILD, also in the AUR
+# Contributor: delta48 <dark.magician.48[at]gmail[dot]com>
+# added just a few touches to make it compile again
+
+pkgname=parsec47
+pkgver=0.2
+pkgrel=2
+pkgdesc="Fast-paced retro shoot'em up in an abstract world"
+arch=('i686' 'x86_64')
+url="http://www.asahi-net.or.jp/~cs8k-cyu/windows/p47_e.html"
+license=('custom')
+depends=('sdl_mixer' 'libbulletml')
+makedepends=('gdc')
+source=("http://abagames.sakura.ne.jp/windows/p47_0_2.zip"
+ "http://ftp.de.debian.org/debian/pool/main/p/${pkgname}/${pkgname}_${pkgver}.dfsg1-6.debian.tar.gz")
+md5sums=('9d90057a269591fe992b7ed44de2d29f'
+ '98d19456f1bf69709b20dbf9fd175ab5')
+
+prepare() {
+ cd $srcdir/p47
+
+ _patchdir="../debian/patches"
+ cat $_patchdir/series | egrep -v '^#|^\ #' | sed "s:^:$_patchdir/:" | xargs -n1 patch -p1 -i
+
+ sed -i 's:/games::g' ./src/abagames/p47/BarrageManager.d
+ sed -i 's:/games::g' ./src/abagames/util/sdl/{Sound,Texture}.d
+ sed -i 's:gdmd-v1:gdmd:' Makefile
+ sed -i 's:gdc-v1:gdc:' Makefile
+}
+
+build() {
+ cd $srcdir/p47
+ make
+}
+
+package() {
+ cd $srcdir/p47
+
+ # Install binaries
+ install -D -m755 $pkgname $pkgdir/usr/bin/$pkgname
+
+ # Install other resources
+ find {images,large,largemove,middle,middlebackmove,middlemove,middlesub,middlesub_lock,morph,morph_lock,small,smallmove,smallsidemove,small_lock,sounds} -type f -exec install -Dm644 {} $pkgdir/usr/share/$pkgname/{} \;
+
+ # Install man page and debian copyright notice
+ install -D -m644 ../debian/$pkgname.6 $pkgdir/usr/share/man/man6/$pkgname.6
+ install -D -m644 ../debian/copyright $pkgdir/usr/share/licenses/$pkgname/copyright
+
+ # Install desktop file and icon
+ install -D -m644 ../debian/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -D -m644 ../debian/$pkgname.xpm $pkgdir/usr/share/pixmaps/$pkgname.xpm
+}