summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-12 21:17:28 -0400
committerJean Lucas2019-04-12 21:17:38 -0400
commit04adc673058d021af5a77c359956bf8288e995d5 (patch)
treee89d09b6a0678506c8fab1bed8efbb22b049d4ea
parentc92cfbf8ead64a44b021a3018a5731ef040943a3 (diff)
downloadaur-04adc673058d021af5a77c359956bf8288e995d5.tar.gz
Version bump, update depends
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 584d1130b4f0..a9d2c12556ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 23 21:39:06 UTC 2018
+# Sat Apr 13 01:17:22 UTC 2019
pkgbase = parsedmarc
pkgdesc = Python package and CLI for parsing aggregate and forensic DMARC reports
- pkgver = 0+159+4853537
+ pkgver = 0+584+536b94f
pkgrel = 1
url = https://domainaware.github.io/parsedmarc
arch = any
@@ -12,7 +12,7 @@ pkgbase = parsedmarc
depends = python-dnspython
depends = python-requests
depends = python-publicsuffix
- depends = python-xmltodict
+ depends = python-xmltodict>=0.12.0
depends = python-pygeoip
depends = python-dnspython
depends = python-imapclient
@@ -26,7 +26,11 @@ pkgbase = parsedmarc
depends = python-collective-checkdocs
depends = python-wheel
depends = rstcheck
- source = git+https://github.com/domainaware/parsedmarc#commit=485353776573fd0a5860b53aa5d97fdbcf7a4456
+ depends = python-tqdm>=4.31.1
+ depends = python-kafka>=1.4.4
+ depends = python-elasticsearch-dsl<7.0.0
+ depends = python-elasticsearch<7.0.0
+ source = git+https://github.com/domainaware/parsedmarc#commit=536b94ff9056c20cec846e41b7ca7853b7cc678f
sha512sums = SKIP
pkgname = parsedmarc
diff --git a/PKGBUILD b/PKGBUILD
index 5e9b58267bdd..1a56caee1084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=parsedmarc
-pkgver=0+159+4853537
-_commit=485353776573fd0a5860b53aa5d97fdbcf7a4456
+pkgver=0+584+536b94f
+_commit=536b94ff9056c20cec846e41b7ca7853b7cc678f
pkgrel=1
pkgdesc='Python package and CLI for parsing aggregate and forensic DMARC reports'
arch=(any)
@@ -11,7 +11,7 @@ license=(Apache)
depends=(python-dnspython
python-requests
python-publicsuffix
- python-xmltodict
+ 'python-xmltodict>=0.12.0'
python-pygeoip
python-dnspython
python-imapclient
@@ -24,10 +24,14 @@ depends=(python-dnspython
python-sphinx_rtd_theme
python-collective-checkdocs
python-wheel
- rstcheck)
+ rstcheck
+ 'python-tqdm>=4.31.1'
+ 'python-kafka>=1.4.4'
+ 'python-elasticsearch-dsl<7.0.0'
+ 'python-elasticsearch<7.0.0')
makedepends=(git python-setuptools)
source=(git+https://github.com/domainaware/parsedmarc#commit=$_commit)
-sha512sums=(SKIP)
+sha512sums=('SKIP')
pkgver() {
cd parsedmarc
@@ -37,5 +41,5 @@ pkgver() {
package() {
cd parsedmarc
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm 644 -t "$pkgdir"/usr/share/licenses/parsedmarc LICENSE
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/parsedmarc
}