summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Abreu2021-10-01 09:36:41 -0400
committerAriel Abreu2021-10-01 09:36:41 -0400
commit1c2fa43d536c2a01d15530be8c1f2e0da832dbe8 (patch)
tree6452cca159382e9084c3cf59a12134954d02f9a9
downloadaur-1c2fa43d536c2a01d15530be8c1f2e0da832dbe8.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..676c3e8c4a0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = partfs-git
+ pkgdesc = FUSE-based file system for accessing partitions on a disk
+ pkgver = v0.1.0.r0.g125ad57
+ pkgrel = 1
+ url = https://github.com/braincorp/partfs
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ makedepends = gcc
+ makedepends = util-linux
+ depends = fuse
+ depends = util-linux-libs
+ provides = partfs
+ conflicts = partfs
+ source = git+https://github.com/braincorp/partfs.git
+ md5sums = SKIP
+
+pkgname = partfs-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9c4df744355e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.zst
+src
+pkg
+partfs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c014434bf7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ariel Abreu <facekapow@outlook.com>
+
+pkgname=partfs-git
+pkgver=v0.1.0.r0.g125ad57
+pkgrel=1
+pkgdesc="FUSE-based file system for accessing partitions on a disk"
+arch=('x86_64')
+url="https://github.com/braincorp/partfs"
+license=('BSD')
+depends=(
+ 'fuse'
+ 'util-linux-libs'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'make'
+ 'gcc'
+ 'util-linux'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/braincorp/partfs.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D -t "$pkgdir/usr/bin" -o root -g root -m 755 build/bin/partfs
+}