summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Brown2020-08-04 00:10:35 -0700
committerWilliam Brown2020-08-04 00:10:35 -0700
commit612f0d78b9fddc724954e0da682e6e167ca5d4dc (patch)
tree9b72707ae897089320d302193b3c321ff47fde3b
downloadaur-612f0d78b9fddc724954e0da682e6e167ca5d4dc.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd678d57b949
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = particle-life-git
+ pkgdesc = A game of life with particles.
+ pkgver = 5
+ pkgrel = 1
+ url = https://github.com/HackerPoet/Particle-Life#readme
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = sfml
+ source = git+https://github.com/HackerPoet/Particle-Life.git
+ md5sums = SKIP
+
+pkgname = particle-life-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..accb1db6279c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: William Brown <glowinthedarkcia@horsefucker.org>
+pkgname="particle-life-git"
+pkgver="5"
+pkgrel="1"
+arch=("x86_64")
+pkgdesc="A game of life with particles."
+url="https://github.com/HackerPoet/Particle-Life#readme"
+source=("git+https://github.com/HackerPoet/Particle-Life.git")
+md5sums=("SKIP")
+license=("MIT")
+depends=("sfml")
+makedepends=("git")
+pkgver() {
+ cd "$srcdir/Particle-Life"
+ git rev-list --count HEAD
+}
+build() {
+ cd "$srcdir/Particle-Life"
+ # Uses GNU-specific features. Using g++ instead of c++.
+ g++ -o particle-life -lsfml-graphics -lsfml-window -lsfml-system \
+ HSV.h Main.cpp Particles.h Universe.cpp Universe.h
+}
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/licenses/particle-life-git"
+ cd "$srcdir/Particle-Life"
+ cp LICENSE "$pkgdir/usr/share/licenses/particle-life-git"
+ cp particle-life "$pkgdir/usr/bin"
+}