summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-04-11 21:07:42 +0200
committersL1pKn072018-04-11 21:07:42 +0200
commitaf4189c200bd31df758f0830fdcdc5f9060cd3e8 (patch)
tree13a2202f640f4892a23919fc20f7fe00b61029da
parent141b37e229493ff78dbec446f5feca7ad9d99434 (diff)
downloadaur-af4189c200bd31df758f0830fdcdc5f9060cd3e8.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c066b3403ef..8c1aa059d760 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Oct 8 15:24:34 UTC 2016
+# Wed Apr 11 19:07:37 UTC 2018
pkgbase = partitionmanager-git
pkgdesc = A KDE utility that allows you to manage disks, partitions, and file systems. (GIT version)
- pkgver = 2.2.1.r1167.bedfee3
+ pkgver = 3.3.1.r1318.8c8e8f8
pkgrel = 1
url = http://kde.org/applications/system/kdepartitionmanager
- arch = i686
arch = x86_64
license = GPL2
makedepends = extra-cmake-modules
@@ -13,6 +12,7 @@ pkgbase = partitionmanager-git
makedepends = git
makedepends = python
depends = kpmcore
+ depends = kde-cli-tools
depends = hicolor-icon-theme
provides = partitionmanager
conflicts = partitionmanager
diff --git a/PKGBUILD b/PKGBUILD
index a77fb4ac27d5..f017082b9ba8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: A Rojas < nqn1976 @ gmail.com >
pkgname=partitionmanager-git
-pkgver=2.2.1.r1167.bedfee3
+pkgver=3.3.1.r1318.8c8e8f8
pkgrel=1
pkgdesc="A KDE utility that allows you to manage disks, partitions, and file systems. (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://kde.org/applications/system/kdepartitionmanager'
license=('GPL2')
depends=('kpmcore'
+ 'kde-cli-tools'
'hicolor-icon-theme'
)
conflicts=('partitionmanager')
@@ -23,7 +24,7 @@ sha256sums=('SKIP')
pkgver() {
cd partitionmanager
- _ver="$(cat CMakeLists.txt | grep -m3 -e VERSION_MAJOR -e VERSION_MINOR -e VERSION_RELEASE | cut -d '"' -f2 | paste -sd'.')"
+ _ver="$(cat CMakeLists.txt | grep -m3 -e MAJOR -e MINOR -e RELEASE | cut -d '"' -f2 | paste -sd'.')"
echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
@@ -34,10 +35,10 @@ prepare() {
build() {
cd build
cmake ../partitionmanager \
- -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
+
make
}