diff options
author | sL1pKn07 | 2023-10-03 17:51:09 +0200 |
---|---|---|
committer | sL1pKn07 | 2023-10-03 17:51:09 +0200 |
commit | c1c2208c27175a342ae6970ec4c6f11c5e7b0a67 (patch) | |
tree | 461d5a46f810835dde38959ddd1054ce83c1d376 | |
parent | d04066fa1e71040eef2c63afbc3e4eb4652d2c5b (diff) | |
download | aur-c1c2208c27175a342ae6970ec4c6f11c5e7b0a67.tar.gz |
bump
-rw-r--r-- | PKGBUILD | 54 |
1 files changed, 35 insertions, 19 deletions
@@ -2,25 +2,42 @@ # Contributor: A Rojas < nqn1976 @ gmail.com > pkgname=partitionmanager-git -pkgver=4.1.0.r1434.d05914c +pkgver=23.11.70.r1851.276c76c pkgrel=1 pkgdesc="A KDE utility that allows you to manage disks, partitions, and file systems. (GIT version)" arch=('x86_64') url='https://kde.org/applications/en/system/org.kde.partitionmanager' license=('GPL2') -depends=('kpmcore' - 'kio' - 'hicolor-icon-theme' - ) +depends=( + 'gcc-libs' # libstdc++.so + 'glibc' # libc.so + 'kpmcore' 'libkpmcore.so' + 'qt5-base' # libQt5Core.so libQt5Gui.so libQt5Widgets.so + 'polkit-qt5' #libpolkit-qt5-core-1.so + 'ki18n5' # libKF5I18n.so + 'kcrash5' # libKF5Crash.so + 'kjobwidgets5' # libKF5JobWidgets.so + 'kconfig5' # libKF5ConfigCore.so libKF5ConfigGui.so libKF5ConfigWidgets.so + 'kdbusaddons5' # libKF5DBusAddons.so + 'kwindowsystem5' # libKF5WindowSystem.so + 'kconfigwidgets5' + 'kio5' # libKF5KIOCore.so libKF5KIOGui.so + 'kxmlgui5' # libKF5XmlGui.so + 'kcoreaddons5' # libKF5CoreAddons.so + 'kwidgetsaddons5' # libKF5WidgetsAddons.so + 'hicolor-icon-theme' +) +makedepends=( + 'extra-cmake-modules' + 'kdoctools' + 'git' + 'python' +) conflicts=('partitionmanager') provides=('partitionmanager') -makedepends=('extra-cmake-modules' - 'kdoctools' - 'git' - 'python' - ) source=('git+https://invent.kde.org/system/partitionmanager.git') sha256sums=('SKIP') +options=('debug') pkgver() { cd partitionmanager @@ -28,20 +45,19 @@ pkgver() { echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)" } -prepare() { - mkdir -p build -} - build() { - cd build - cmake ../partitionmanager \ + cmake -S partitionmanager -B build \ -DCMAKE_INSTALL_PREFIX=/usr \ -DKDE_INSTALL_LIBDIR=lib \ - -DBUILD_TESTING=OFF + -DBUILD_TESTING=ON + + cmake --build build +} - make +check() { + ctest --test-dir build --output-on-failure } package() { - make -C build DESTDIR="${pkgdir}" install + DESTDIR="${pkgdir}" cmake --install build } |