summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:10:04 +0200
committersl1pkn072015-06-08 19:10:04 +0200
commite7c438b60c7a0802e16c247f2176971449b15adb (patch)
tree603cb8a061c1f73deeb864e2dbf9fb508e5859d4
downloadaur-e7c438b60c7a0802e16c247f2176971449b15adb.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
-rw-r--r--partitionmanager-git.install11
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d12c9e1ad36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = partitionmanager-git
+ pkgdesc = A KDE utility that allows you to manage disks, partitions, and file systems
+ pkgver = 1.2.1.r922.b651d8d
+ pkgrel = 1
+ url = http://kde.org/applications/system/kdepartitionmanager/
+ install = partitionmanager-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = python
+ depends = kmpcore-git
+ depends = hicolor-icon-theme
+ optdepends = e2fsprogs: ext2/3/4 support
+ optdepends = xfsprogs: XFS support
+ optdepends = jfsutils: JFS support
+ optdepends = reiserfsprogs: Reiser support
+ optdepends = ntfsprogs: NTFS support
+ optdepends = dosfstools: FAT32 support
+ provides = partitionmanager
+ conflicts = partitionmanager
+ source = git://anongit.kde.org/partitionmanager#branch=kpmcore
+ sha1sums = SKIP
+
+pkgname = partitionmanager-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..50f448d55720
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!partitionmanager-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..656659f6b737
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: A Rojas < nqn1976 @ gmail.com >
+
+pkgname=partitionmanager-git
+pkgver=1.2.1.r922.b651d8d
+pkgrel=1
+pkgdesc="A KDE utility that allows you to manage disks, partitions, and file systems"
+arch=('i686' 'x86_64')
+url='http://kde.org/applications/system/kdepartitionmanager/'
+license=('GPL2')
+depends=('kmpcore-git' 'hicolor-icon-theme')
+conflicts=('partitionmanager')
+provides=('partitionmanager')
+makedepends=('cmake' 'git' 'extra-cmake-modules' 'kdoctools' 'python')
+optdepends=('e2fsprogs: ext2/3/4 support'
+ 'xfsprogs: XFS support'
+ 'jfsutils: JFS support'
+ 'reiserfsprogs: Reiser support'
+ 'ntfsprogs: NTFS support'
+ 'dosfstools: FAT32 support')
+source=('git://anongit.kde.org/partitionmanager#branch=kpmcore')
+sha1sums=('SKIP')
+install=partitionmanager-git.install
+
+pkgver() {
+ cd partitionmanager
+ _ver="$(cat CMakeLists.txt | grep -e VERSION_MAJOR -e VERSION_MINOR -e VERSION_RELEASE | head -n3 | cut -d '"' -f2)"
+ echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../partitionmanager \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+} \ No newline at end of file
diff --git a/partitionmanager-git.install b/partitionmanager-git.install
new file mode 100644
index 000000000000..e70c054ec6ad
--- /dev/null
+++ b/partitionmanager-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}