summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Berryhill2018-09-06 17:41:39 -0400
committerThomas Berryhill2018-09-06 17:41:39 -0400
commit67229e3f070ebf4b2a721ced2f7c36ece867e27e (patch)
treeca81070a2df8edec3e573f909a3bde917526cea4
downloadaur-67229e3f070ebf4b2a721ced2f7c36ece867e27e.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c296362efec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = partytube-git
+ pkgdesc = An internet video jukebox
+ pkgver = r3.b26a3dc
+ pkgrel = 1
+ url = https://github.com/oatberry/partytube
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ depends = mpv
+ depends = youtube-dl
+ options = !strip
+ options = !emptydirs
+ source = partytube-git::git+https://github.com/oatberry/partytube
+ md5sums = SKIP
+
+pkgname = partytube-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cfed7bce885
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Thomas Berryhill <oats at oatberry dot me>
+
+pkgname=partytube-git
+pkgver=r3.b26a3dc
+pkgrel=1
+pkgdesc="An internet video jukebox"
+arch=('any')
+url="https://github.com/oatberry/partytube"
+license=('GPL3')
+depends=('mpv' 'youtube-dl')
+makedepends=('git' 'go')
+options=('!strip' '!emptydirs')
+source=($pkgname::git+https://github.com/oatberry/partytube)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ go build -o partytube
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -p -m755 partytube "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ install -m 0644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/"
+}