summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato TOYOSHIMA2024-03-28 13:48:48 +0900
committerMasato TOYOSHIMA2024-03-28 13:48:48 +0900
commitbc3c246a3180d6b3110de8f847ef918680756ff2 (patch)
tree34df8e052ada41f7fbf0869f0554839a60bfc75c
parentd55d7d7a5c5756c3a9abfeed546ad7420a808d46 (diff)
downloadaur-bc3c246a3180d6b3110de8f847ef918680756ff2.tar.gz
-ffat-lto-objects only gcc
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a11dc538dcf2..e6d1b67ad2b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,9 @@ sha256sums=('ccf6defc4884d580a4b813cc40323a0389ffc9aa4bdc55f3764a46b235dfe1e0'
'SKIP')
# Add -ffat-lto-objects flag to LTOFLAGS to prevent mangling of static libs.(gcc)
-export LTOFLAGS+=" -ffat-lto-objects"
+# In clang-16, there seems to be no problem without this option specified.
+# (The -ffat-lto-objects option is planned to be supported from clang-17.)
+[[ $CC =~ gcc ]] && export LTOFLAGS+=" -ffat-lto-objects"
# musl build for openssl-sys
export PKG_CONFIG_ALLOW_CROSS=1
export RUSTUP_TOOLCHAIN=stable