summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Büchau2020-01-14 21:54:36 +0100
committerYann Büchau2020-01-14 22:25:02 +0100
commit9814b90d398ff74ae399ad42bcfde3383bc7320f (patch)
tree4f5af62d2d4529bfeace0c68c1a171d086d583f6
downloadaur-9814b90d398ff74ae399ad42bcfde3383bc7320f.tar.gz
PKGBUILD for v0.55
- adopted from PKGBUILD from archtux found at https://github.com/felixonmars/aur3-mirror
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rwxr-xr-xPKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33f479d41e73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pasaffe
+ pkgdesc = Easy to use password manager for Gnome with a Password Safe 3.0 compatible database.
+ pkgver = 0.55
+ pkgrel = 1
+ url = https://launchpad.net/pasaffe
+ arch = any
+ license = GPL3
+ makedepends = python-distutils-extra
+ depends = apg
+ depends = gtk3
+ depends = python-gobject
+ depends = python-unidecode
+ depends = yelp
+ source = http://launchpad.net/pasaffe/trunk/0.55/+download/pasaffe-0.55.tar.gz
+ md5sums = e535aafeee6e1684b2a506bd9c463da5
+
+pkgname = pasaffe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce4d7f5ec50b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.?z
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7d6e0ee01304
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Based on a PKGBUILD for pasaffe found at https://github.com/felixonmars/aur3-mirror
+# Previous Maintainer: archtux <antonio dot arias99999 at gmail dot com>
+# Maintainer: nobodyinperson <nobodyinperson at posteo de>
+pkgname=pasaffe
+pkgver=0.55
+pkgrel=1
+pkgdesc="Easy to use password manager for Gnome with a Password Safe 3.0 compatible database."
+arch=('any')
+url="https://launchpad.net/pasaffe"
+license=('GPL3')
+depends=(
+ 'apg'
+ 'gtk3'
+ 'python-gobject'
+ 'python-unidecode'
+ 'yelp'
+)
+makedepends=('python-distutils-extra')
+install=
+source=(http://launchpad.net/pasaffe/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz)
+md5sums=('e535aafeee6e1684b2a506bd9c463da5')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python setup.py install --root "$pkgdir" --optimize=1
+}