summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Demkowicz-Duffy2020-02-14 12:33:02 +0000
committerLaura Demkowicz-Duffy2020-02-14 12:33:02 +0000
commitc52d5688d142d2c2efae2e8ad56f3c7a1a61008a (patch)
tree6f466d40290fc22f3891954148fa2a1d54d0550b
parentcc38fc8679e66387b99c292bcc063b19c439e1a6 (diff)
downloadaur-c52d5688d142d2c2efae2e8ad56f3c7a1a61008a.tar.gz
Add patched shell script to start the compiler and run the result
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--path_fix.patch10
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e727884b1eb..7fcf88f4d4e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pascal-fc
pkgdesc = An implementation of pascal with extra constructs for teaching concurrent programming
pkgver = 1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/danieljabailey/Pascal-FC
arch = x86_64
license = GPL2
@@ -9,7 +9,9 @@ pkgbase = pascal-fc
depends = fpc
depends = git
source = pascal-fc::git+git://github.com/danieljabailey/Pascal-FC
+ source = path_fix.patch
md5sums = SKIP
+ md5sums = 8d52b2db9b651db21402b3f4f6fa9af9
pkgname = pascal-fc
diff --git a/PKGBUILD b/PKGBUILD
index 59b470bff4bc..032d7498b110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pascal-fc
pkgver=1
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="An implementation of pascal with extra constructs for teaching concurrent programming"
arch=('x86_64')
@@ -10,18 +10,26 @@ url="https://github.com/danieljabailey/Pascal-FC"
license=('GPL2')
depends=('fpc' 'git')
makedepends=('fpc')
-source=('pascal-fc::git+git://github.com/danieljabailey/Pascal-FC')
+source=('pascal-fc::git+git://github.com/danieljabailey/Pascal-FC'
+ 'path_fix.patch')
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '8d52b2db9b651db21402b3f4f6fa9af9')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch --forward --strip=1 --input="${srcdir}/path_fix.patch"
+}
build() {
- cd "$pkgname"
+ cd "$srcdir/$pkgname"
make pfccomp
make pint
}
package() {
- cd "$pkgname"
+ cd "$srcdir/$pkgname"
install -D pfccomp $pkgdir/usr/bin/pfccomp
install -D pint $pkgdir/usr/bin/pint
+ install -D pfc.sh $pkgdir/usr/bin/pfc
}
diff --git a/path_fix.patch b/path_fix.patch
new file mode 100644
index 000000000000..57ff9dc1feae
--- /dev/null
+++ b/path_fix.patch
@@ -0,0 +1,10 @@
+--- pascal-fc.orig/pfc.sh 2020-02-14 12:15:44.650336401 +0000
++++ pascal-fc.new/pfc.sh 2020-02-14 12:26:18.301776721 +0000
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-p=$PWD
++p=/usr/bin
+ if test -f objfile
+ then rm objfile
+ fi