summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbdelhakim Qbaich2019-11-30 16:25:42 -0500
committerAbdelhakim Qbaich2019-11-30 16:25:42 -0500
commit4ae249c595353daac06f8b3332f7207ebfc7b804 (patch)
tree2595ea6061c438bb28d828f3fd7c20ebc06e5681
downloadaur-4ae249c595353daac06f8b3332f7207ebfc7b804.tar.gz
Initial commit - Version 2.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27d531a6def0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pash
+ pkgdesc = A simple password manager using GPG written in POSIX sh
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://github.com/dylanaraps/pash
+ arch = any
+ license = MIT
+ depends = gnupg
+ depends = tree
+ depends = xclip
+ source = https://github.com/dylanaraps/pash/archive/2.3.0.tar.gz
+ sha256sums = 7ee6a649d80350b8b52b1b7ad78d687775a3cc145fecbd3a75d34865c31dd7ef
+
+pkgname = pash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dffcdb3d899b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Abdelhakim Qbaich <abdelhakim@qbaich.com>
+
+pkgname='pash'
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='A simple password manager using GPG written in POSIX sh'
+arch=('any')
+url="https://github.com/dylanaraps/$pkgname"
+license=('MIT')
+depends=('gnupg' 'tree' 'xclip')
+source=("https://github.com/dylanaraps/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('7ee6a649d80350b8b52b1b7ad78d687775a3cc145fecbd3a75d34865c31dd7ef')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+}