summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Lehmann2017-06-10 14:22:39 +0200
committerAlexander Lehmann2017-06-10 14:22:39 +0200
commit0de144f0089ba9f63adfaff607606a8707bbaec7 (patch)
tree8b8352bae0a3ba71a626b74f3f0274a8fcb87baf
downloadaur-pasmo.tar.gz
Initial commit of pasmo 0.5.4.beta2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51393eb3c697
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pasmo
+ pkgdesc = Portable Z80 cross assembler
+ pkgver = 0.5.4.beta2
+ pkgrel = 1
+ url = http://pasmo.speccy.org/
+ arch = any
+ license = GPLv2
+ source = http://pasmo.speccy.org/bin/pasmo-0.5.4.beta2.tgz
+ md5sums = c85b0b7935ea174f9a57821019f464fa
+
+pkgname = pasmo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..454d7da00a95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Alexander Lehmann <afwlehmann@googlemail.com>
+pkgname=pasmo
+pkgver=0.5.4.beta2
+pkgrel=1
+epoch=
+pkgdesc="Portable Z80 cross assembler"
+arch=('any')
+url="http://pasmo.speccy.org/"
+license=('GPLv2')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://pasmo.speccy.org/bin/$pkgname-$pkgver.tgz")
+noextract=()
+md5sums=(c85b0b7935ea174f9a57821019f464fa)
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ AUTHORS \
+ COPYING \
+ ChangeLog \
+ INSTALL \
+ NEWS \
+ README \
+ pasmodoc.html
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}/examples" *.asm
+}