summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Pujol2018-02-24 18:28:43 +0000
committerAlexandre Pujol2018-02-24 18:28:43 +0000
commitaf825b94da9f1efd01c8abaacebb700749fa3633 (patch)
tree66e3b858daf14c0324ca139a6ddc6eb42f264b85
downloadaur-af825b94da9f1efd01c8abaacebb700749fa3633.tar.gz
pass audit 0.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e975f206e029
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pass-audit
+ pkgdesc = A pass extension for auditing your password repository.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/roddhjav/pass-audit
+ arch = any
+ license = GPL3
+ depends = pass
+ depends = python
+ depends = python-requests
+ source = https://github.com/roddhjav/pass-audit/releases/download/v0.1/pass-audit-0.1.tar.gz
+ source = https://github.com/roddhjav/pass-audit/releases/download/v0.1/pass-audit-0.1.tar.gz.asc
+ validpgpkeys = 06A26D531D56C42D66805049C5469996F0DF68EC
+ sha512sums = 3ffc3ef64145f7eb7236804dcce710fe240fe1665a59e850509d17466d1c6b4ffc58d7d3143545f29a4b7d572aa4f8fd332cd4cbe54f8dac4479cb119a015172
+ sha512sums = 3c748b4c30ac6ea6a7cfcac11dc43711e403bcdcc1c0132aee923c2608c00030bb695dc9edaa90136ff1f99c99667b7bb2d0c6a7f4c9f2451c7d0233c4375a54
+
+pkgname = pass-audit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64b2439e4126
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexandre Pujol <alexandre@pujol.io>
+
+pkgname='pass-audit'
+pkgver=0.1
+pkgrel=1
+pkgdesc='A pass extension for auditing your password repository.'
+arch=('any')
+url='https://github.com/roddhjav/pass-audit'
+license=('GPL3')
+depends=('pass' 'python' 'python-requests')
+source=(https://github.com/roddhjav/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz
+ https://github.com/roddhjav/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz.asc)
+sha512sums=('3ffc3ef64145f7eb7236804dcce710fe240fe1665a59e850509d17466d1c6b4ffc58d7d3143545f29a4b7d572aa4f8fd332cd4cbe54f8dac4479cb119a015172'
+'3c748b4c30ac6ea6a7cfcac11dc43711e403bcdcc1c0132aee923c2608c00030bb695dc9edaa90136ff1f99c99667b7bb2d0c6a7f4c9f2451c7d0233c4375a54')
+
+# The public key is found at https://pujol.io/keys
+# gpg --recv-keys 06A26D531D56C42D66805049C5469996F0DF68EC
+validpgpkeys=('06A26D531D56C42D66805049C5469996F0DF68EC')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ make DESTDIR="${pkgdir}" FORCE_ALL=1 install
+}