aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Francisco2018-07-31 23:14:11 +0100
committerXavier Francisco2018-07-31 23:14:11 +0100
commit23364771b641a11c50e127f7fd4a351a2d70c120 (patch)
tree99b691b26804f5036f5897cf44f124e1775ee494
downloadaur-23364771b641a11c50e127f7fd4a351a2d70c120.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD36
-rw-r--r--README.md2
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e46ab6e44638
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pass-file-git
+ pkgdesc = A pass extension that allows to add files to your password-store.
+ pkgver = r7.1c7e6a0
+ pkgrel = 1
+ url = https://github.com/dvogt23/pass-file
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = sed
+ depends = pass
+ provides = pass-file
+ conflicts = pass-file
+ backup = etc/pass-file/pass-file.conf
+ source = pass-file::git+https://github.com/dvogt23/pass-file.git
+ md5sums = SKIP
+
+pkgname = pass-file-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5a53770e2dc9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Xavier Francisco
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d50c19aa187e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Xavier Francisco <echo moc.liamg@ocsicnarf.n.reivax | rev>
+
+# PKGBUILD script for pass-file upstream, git version
+# pony-file adds support to files using pass
+_pkgname=pass-file
+pkgname=$_pkgname-git
+pkgver=r7.1c7e6a0
+pkgrel=1
+pkgdesc=" A pass extension that allows to add files to your password-store."
+arch=('i686' 'x86_64')
+url="https://github.com/dvogt23/pass-file"
+license=('GPL3')
+groups=()
+depends=('pass')
+makedepends=('git' 'sed')
+# optdepends=('***: for that thing *** does')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+backup=("etc/$_pkgname/$_pkgname.conf")
+source=("$_pkgname::git+https://github.com/dvogt23/pass-file.git")
+md5sums=('SKIP')
+pkgdir="/usr/lib"
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# package() {
+# make DESTDIR="$pkgdir/" install
+# }
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="${pkgdir}" FORCE_ALL=1 install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..914b0f3986bc
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# pass-file-pkgbuild
+PKGBUILD for pass file extension