summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2020-06-30 09:44:41 +1200
committerMorgenstern2020-06-30 09:44:41 +1200
commit6e32af536dff4811eaf450eb4082b2eb20de10ef (patch)
treef7b959fe9ed2e486b93f396db99de23ca08571aa
parentbf2ad32447b06ddf306e72b939d871f1e726badf (diff)
downloadaur-6e32af536dff4811eaf450eb4082b2eb20de10ef.tar.gz
Removed extended passmenu patch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD42
-rw-r--r--passmenu-extended.patch96
3 files changed, 24 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b1fb080ffe2..f9a672252031 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pass-parcellite
- pkgdesc = Stores, retrieves, generates, and synchronizes passwords securely (Parcellite and extended passmenu support)
+ pkgdesc = Stores, retrieves, generates, and synchronizes passwords securely (Parcellite support)
pkgver = 1.7.3
- pkgrel = 4
+ pkgrel = 5
url = https://www.passwordstore.org/
arch = any
license = GPL2
@@ -10,12 +10,11 @@ pkgbase = pass-parcellite
depends = bash
depends = gnupg
depends = tree
- optdepends = parcellite-git: for Parcellite support
- optdepends = git: for Git support
optdepends = dmenu: for passmenu
+ optdepends = git: for Git support
+ optdepends = parcellite-git: for Parcellite support [AUR]
optdepends = qrencode: for QR code support
optdepends = xdotool: for typing support
- optdepends = pass-otp: for OTP support
provides = passmenu
provides = pass
conflicts = passmenu
@@ -23,10 +22,8 @@ pkgbase = pass-parcellite
replaces = passmenu
source = https://git.zx2c4.com/password-store/snapshot/password-store-1.7.3.tar.xz
source = pass-parcellite.patch
- source = passmenu-extended.patch
sha256sums = 2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4
sha256sums = 451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155
- sha256sums = f714cf5edebc5971eaa8d81111d5ebf20e738af18e7a9047434c1290ed548114
pkgname = pass-parcellite
diff --git a/PKGBUILD b/PKGBUILD
index 7fd170786508..500f18978728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,38 @@
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Simon Zimmermann <simon@insmo.com>
-pkgname='pass-parcellite'
+pkgname=pass-parcellite
pkgver=1.7.3
-pkgrel=4
-pkgdesc='Stores, retrieves, generates, and synchronizes passwords securely (Parcellite and extended passmenu support)'
+pkgrel=5
+pkgdesc='Stores, retrieves, generates, and synchronizes passwords securely (Parcellite support)'
arch=('any')
-url='https://www.passwordstore.org/'
+url="https://www.passwordstore.org/"
license=('GPL2')
-depends=('xclip' 'bash' 'gnupg' 'tree')
+depends=('xclip'
+ 'bash'
+ 'gnupg'
+ 'tree')
checkdepends=('git')
-optdepends=('parcellite-git: for Parcellite support'
- 'git: for Git support'
- 'dmenu: for passmenu'
- 'qrencode: for QR code support'
- 'xdotool: for typing support'
- 'pass-otp: for OTP support')
+optdepends=('dmenu: for passmenu'
+ 'git: for Git support'
+ 'parcellite-git: for Parcellite support [AUR]'
+ 'qrencode: for QR code support'
+ 'xdotool: for typing support')
replaces=('passmenu')
-provides=('passmenu' 'pass')
-conflicts=('passmenu' 'pass')
+provides=('passmenu'
+ 'pass')
+conflicts=('passmenu'
+ 'pass')
source=("https://git.zx2c4.com/password-store/snapshot/password-store-${pkgver}.tar.xz"
- "pass-parcellite.patch"
- "passmenu-extended.patch")
+ 'pass-parcellite.patch')
sha256sums=('2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4'
- '451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155'
- 'f714cf5edebc5971eaa8d81111d5ebf20e738af18e7a9047434c1290ed548114')
+ '451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155')
prepare() {
cd "${srcdir}/password-store-$pkgver/"
# Parcellite history removal support
# https://github.com/rickyrockrat/parcellite/commit/fa54161d0ea83357d817d3d16b6ef3f503bafc09
patch --forward --strip=1 --input="${srcdir}/pass-parcellite.patch"
- # Extend "passmenu" (typing and OTP)
- # https://lists.zx2c4.com/pipermail/password-store/2015-December/001834.html
- # https://github.com/tadfisher/pass-otp
- patch --forward --strip=1 --input="${srcdir}/passmenu-extended.patch"
}
check() {
@@ -48,5 +46,5 @@ package() {
make DESTDIR="${pkgdir}" WITH_ALLCOMP=yes install
cd contrib/dmenu
- install -Dm0755 passmenu "${pkgdir}/usr/bin/passmenu"
+ install -D passmenu "${pkgdir}/usr/bin/passmenu"
}
diff --git a/passmenu-extended.patch b/passmenu-extended.patch
deleted file mode 100644
index 6aaddf930e01..000000000000
--- a/passmenu-extended.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-diff --unified --recursive --text password-store-1.7.3/contrib/dmenu/passmenu password-store-1.7.3.new/contrib/dmenu/passmenu
---- password-store-1.7.3/contrib/dmenu/passmenu 2020-05-07 10:15:53.692356060 +1200
-+++ password-store-1.7.3.new/contrib/dmenu/passmenu 2020-05-07 10:11:21.246208556 +1200
-@@ -8,6 +8,30 @@
- shift
- fi
-
-+typeuser=0
-+if [[ $1 == "--typeuser" ]]; then
-+ typeuser=1
-+ shift
-+fi
-+
-+typeboth=0
-+if [[ $1 == "--typeboth" ]]; then
-+ typeboth=1
-+ shift
-+fi
-+
-+otp=0
-+if [[ $1 == "--otp" ]]; then
-+ otp=1
-+ shift
-+fi
-+
-+typeotp=0
-+if [[ $1 == "--typeotp" ]]; then
-+ typeotp=1
-+ shift
-+fi
-+
- prefix=${PASSWORD_STORE_DIR-~/.password-store}
- password_files=( "$prefix"/**/*.gpg )
- password_files=( "${password_files[@]#"$prefix"/}" )
-@@ -17,9 +41,24 @@
-
- [[ -n $password ]] || exit
-
--if [[ $typeit -eq 0 ]]; then
-- pass show -c "$password" 2>/dev/null
--else
-+if [[ $typeit -eq 1 ]]; then
-+ pass show "$password" | { IFS= read -r pass; printf %s "$pass"; } |
-+ xdotool type --clearmodifiers --file -
-+elif [[ $typeuser -eq 1 ]]; then
-+ pass show "$password" | awk 'BEGIN{ORS="\t"} NR==2 {print; exit}' |
-+ sed 's/user\:\s//' | # Specify a custom filter if needed
-+ xdotool type --clearmodifiers --file -
-+elif [[ $typeboth -eq 1 ]]; then
-+ pass show "$password" | awk 'BEGIN{ORS="\t"} NR==2 {print; exit}' |
-+ sed 's/user\:\s//' | # Specify a custom filter if needed
-+ xdotool type --clearmodifiers --file -
- pass show "$password" | { IFS= read -r pass; printf %s "$pass"; } |
- xdotool type --clearmodifiers --file -
-+elif [[ $otp -eq 1 ]]; then
-+ pass otp -c "$password" 2>/dev/null
-+elif [[ $typeotp -eq 1 ]]; then
-+ pass otp "$password" | { IFS= read -r pass; printf %s "$pass"; } |
-+ xdotool type --clearmodifiers --file -
-+else
-+ pass show -c "$password" 2>/dev/null
- fi
-diff --unified --recursive --text password-store-1.7.3/contrib/dmenu/README.md password-store-1.7.3.new/contrib/dmenu/README.md
---- password-store-1.7.3/contrib/dmenu/README.md 2020-05-07 10:15:27.296221593 +1200
-+++ password-store-1.7.3.new/contrib/dmenu/README.md 2020-05-07 10:09:48.133462161 +1200
-@@ -1,13 +1,24 @@
- `passmenu` is a [dmenu][]-based interface to [pass][], the standard Unix
- password manager. This design allows you to quickly copy a password to the
- clipboard without having to open up a terminal window if you don't already have
--one open. If `--type` is specified, the password is typed using [xdotool][]
--instead of copied to the clipboard.
-+one open.
-+
-+If `--type` is specified, the password is typed using [xdotool][]
-+instead of copied to the clipboard. If `--typeuser` is specified, the
-+second line is typed using [xdotool][] (ideally the username). If `--typeboth`
-+is specified, the second line is typed using [xdotool][] first (ideally the
-+username), then tab, then the first line.
-+
-+If [pass-otp][] is installed and `--typeotp` is specified, the otpauth URI
-+is used to generate a token that is typed using [xdotool][]. If `--otp` is
-+specified, the otpauth URI is used to generate a token that is copied to
-+the clipboard.
-
- # Usage
-
-- passmenu [--type] [dmenu arguments...]
-+ passmenu [--type | --typeuser | --typeboth | --typeotp | --otp] [dmenu arguments...]
-
--[dmenu]: http://tools.suckless.org/dmenu/
--[xdotool]: http://www.semicomplete.com/projects/xdotool/
--[pass]: http://www.zx2c4.com/projects/password-store/
-+[dmenu]: https://tools.suckless.org/dmenu/
-+[xdotool]: https://www.semicomplete.com/projects/xdotool/
-+[pass]: https://www.zx2c4.com/projects/password-store/
-+[pass-otp]: https://github.com/tadfisher/pass-otp