summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2019-04-20 15:22:39 +1200
committerMorgenstern2019-04-20 15:22:39 +1200
commitee19f9ff3dbb4753a19e25c7afdd2dbc61148682 (patch)
tree8aac4b6cd36db1b4a20523a17f08cf7828b33073
parent3ea93debbb3d8f7530299a32ae2b665f50ab6176 (diff)
downloadaur-ee19f9ff3dbb4753a19e25c7afdd2dbc61148682.tar.gz
Simplified patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--pass-parcellite.patch25
3 files changed, 10 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 147d1d1005d2..ca1a8381acdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pass-parcellite
pkgdesc = Stores, retrieves, generates, and synchronizes passwords securely (Parcellite history removal support)
pkgver = 1.7.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.passwordstore.org/
arch = any
license = GPL2
@@ -22,7 +22,7 @@ pkgbase = pass-parcellite
source = https://git.zx2c4.com/password-store/snapshot/password-store-1.7.3.tar.xz
source = pass-parcellite.patch
sha256sums = 2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4
- sha256sums = f37dcc73d214fc9435e499f4b4c153fa93e923bd9dc7fe3d8fc1821119054fb1
+ sha256sums = 451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155
pkgname = pass-parcellite
diff --git a/PKGBUILD b/PKGBUILD
index 9967243ca8cb..84a189bccbd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='pass-parcellite'
pkgver=1.7.3
-pkgrel=1
+pkgrel=2
pkgdesc='Stores, retrieves, generates, and synchronizes passwords securely (Parcellite history removal support)'
arch=('any')
url='https://www.passwordstore.org/'
@@ -20,7 +20,7 @@ conflicts=('passmenu' 'pass')
source=("https://git.zx2c4.com/password-store/snapshot/password-store-${pkgver}.tar.xz"
"pass-parcellite.patch")
sha256sums=('2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4'
- 'f37dcc73d214fc9435e499f4b4c153fa93e923bd9dc7fe3d8fc1821119054fb1')
+ '451a0e4b09cb56fa57382a6ee30f646fe7734658c709dbe6e2411cafe75af155')
prepare() {
cd "${srcdir}/password-store-$pkgver/"
diff --git a/pass-parcellite.patch b/pass-parcellite.patch
index f2a5d1072cd0..b8c1f689baf9 100644
--- a/pass-parcellite.patch
+++ b/pass-parcellite.patch
@@ -1,26 +1,13 @@
diff --unified --recursive --text password-store-1.7.3.orig/src/password-store.sh password-store-1.7.3.new/src/password-store.sh
--- password-store-1.7.3.orig/src/password-store.sh 2018-08-03 15:32:48.000000000 +1200
-+++ password-store-1.7.3.new/src/password-store.sh 2019-04-20 14:09:13.702924600 +1200
-@@ -155,7 +155,8 @@
- # variable. Specifically, it cannot store nulls nor (non-trivally) store
- # trailing new lines.
- local sleep_argv0="password store sleep on display $DISPLAY"
-- pkill -f "^$sleep_argv0" 2>/dev/null && sleep 0.5
-+ # Allow multiple $sleep_argv0 processes
-+ #pkill -f "^$sleep_argv0" 2>/dev/null && sleep 0.5
- local before="$(xclip -o -selection "$X_SELECTION" 2>/dev/null | $BASE64)"
- echo -n "$1" | xclip -selection "$X_SELECTION" || die "Error: Could not copy data to the clipboard"
- (
-@@ -173,6 +174,12 @@
++++ password-store-1.7.3.new/src/password-store.sh 2019-04-20 15:17:19.671661200 +1200
+@@ -172,6 +172,9 @@
+ # so we axe it here:
qdbus org.kde.klipper /klipper org.kde.klipper.klipper.clearClipboardHistory &>/dev/null
- echo "$before" | $BASE64 -d | xclip -selection "$X_SELECTION"
++ # Clear Parcellite clipboard history
++ echo -n "clear_all" > "$HOME"/.local/share/parcellite/fifo_cmd 2>/dev/null
+
-+ # Wait until all $sleep_argv0 processes have cleared, then
-+ # wipe the Parcellite clipboard history
-+ while pgrep -f "^$sleep_argv0" 2>/dev/null; do
-+ :
-+ done; echo -n "clear_all" > "$HOME"/.local/share/parcellite/fifo_cmd
+ echo "$before" | $BASE64 -d | xclip -selection "$X_SELECTION"
) >/dev/null 2>&1 & disown
echo "Copied $2 to clipboard. Will clear in $CLIP_TIME seconds."
- }