summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Agarwal2022-08-03 21:58:56 +0530
committerAyush Agarwal2022-08-03 21:58:56 +0530
commitd1ae8bdd38896344b958b630c507511676aacb24 (patch)
treedc9c3880c44da4ba9d84f58ba5819f95186b82e1
parent284afecdb24a9f4c45f4f90338889b2b936f06b9 (diff)
downloadaur-d1ae8bdd38896344b958b630c507511676aacb24.tar.gz
release: bump pass-tessen version to 2.0.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
-rw-r--r--pass-tessen.install21
3 files changed, 52 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d332abbb6fc..5182751eef9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = pass-tessen
- pkgdesc = A fuzzy data selection and copying interface for pass
- pkgver = 1.5.3
+ pkgdesc = fuzzy data selection and copy-paste from password store
+ pkgver = 2.0.1
pkgrel = 1
- url = https://github.com/ayushnix/pass-tessen
- arch = x86_64
- license = GPL
+ url = https://git.sr.ht/~ayushnix/pass-tessen
+ install = pass-tessen.install
+ arch = any
+ license = GPL2
depends = pass
- depends = fzf
+ optdepends = fzf: supported fuzzy selection backend
+ optdepends = skim: supported fuzzy selection backend
+ optdepends = fzy: supported fuzzy selection backend
optdepends = wl-clipboard: to copy text in wayland
- optdepends = wl-clipboard-rs: to copy text in wayland
optdepends = xclip: to copy text in xorg
+ optdepends = xdg-utils: to open URLs in default web browser
+ optdepends = pass-otp: to generate and copy OTPs
conflicts = pass-tessen-git
- source = pass-tessen-1.5.3.tar.gz::https://github.com/ayushnix/pass-tessen/archive/refs/tags/v1.5.3.tar.gz
- sha256sums = 67a7b17d7a3099c0660f54a638238b8250d5fdef319ba10f5a147fc7cd39f600
+ source = https://git.sr.ht/~ayushnix/pass-tessen/refs/download/v2.0.1/pass-tessen-2.0.1.tar.gz
+ sha256sums = 83ae103ba8c21018b104f748716240724a0a56d7ede4773fef31c6e77c20d0d7
pkgname = pass-tessen
diff --git a/PKGBUILD b/PKGBUILD
index 4cd60a1060ad..51ead64379fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# Maintainer: Ayush Agarwal <ayush at fastmail dot in>
+# Maintainer: Ayush Agarwal <ayushnix at fastmail dot com>
pkgname=pass-tessen
-pkgver=1.5.3
+pkgver=2.0.1
pkgrel=1
-pkgdesc="A fuzzy data selection and copying interface for pass"
-arch=(x86_64)
-url="https://github.com/ayushnix/pass-tessen"
-license=('GPL')
-depends=('pass'
- 'fzf')
-optdepends=('wl-clipboard: to copy text in wayland'
- 'wl-clipboard-rs: to copy text in wayland'
- 'xclip: to copy text in xorg')
+pkgdesc="fuzzy data selection and copy-paste from password store"
+arch=(any)
+url="https://git.sr.ht/~ayushnix/pass-tessen"
+license=('GPL2')
+depends=('pass')
+optdepends=(
+ 'fzf: supported fuzzy selection backend'
+ 'skim: supported fuzzy selection backend'
+ 'fzy: supported fuzzy selection backend'
+ 'wl-clipboard: to copy text in wayland'
+ 'xclip: to copy text in xorg'
+ 'xdg-utils: to open URLs in default web browser'
+ 'pass-otp: to generate and copy OTPs')
conflicts=('pass-tessen-git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ayushnix/pass-tessen/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('67a7b17d7a3099c0660f54a638238b8250d5fdef319ba10f5a147fc7cd39f600')
+source=("$url/refs/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('83ae103ba8c21018b104f748716240724a0a56d7ede4773fef31c6e77c20d0d7')
+install=pass-tessen.install
package() {
cd "$pkgname-$pkgver"
diff --git a/pass-tessen.install b/pass-tessen.install
new file mode 100644
index 000000000000..38a03fa44264
--- /dev/null
+++ b/pass-tessen.install
@@ -0,0 +1,21 @@
+post_install() {
+ printf "%s" "\
+pass-tessen needs at least one
+
+- fuzzy data selection backend (fzf or skim or fzy)
+- clipboard backend (wl-clipboard or xlcip)
+
+to work. Please install the backends you prefer to use after installing pass-tessen.
+"
+}
+
+post_upgrade() {
+ printf "%s" "\
+pass-tessen v2.0.1 has some major changes since the v1.5.3 release. Please read
+the output of
+
+pass tessen -h
+
+for more details
+"
+}