diff options
author | jenic | 2025-04-12 10:02:04 -0400 |
---|---|---|
committer | jenic | 2025-04-12 10:02:04 -0400 |
commit | bc88823da270be36ba98305432e7937005c07da8 (patch) | |
tree | b4ed1f16d4944c2ac51e16f2a563df23cbdcd10d | |
parent | 2de76d7db33ea11803264c2c4d32c046a297d828 (diff) | |
download | aur-bc88823da270be36ba98305432e7937005c07da8.tar.gz |
Modify pkgver() method; version bump
* Modify pkgver() to use revisions as passage project doesn't use tags
* Bumped pkgver to newly expected value with hard-coded password-store
version to maintain monotonicity
* Subsequent version bumps will use pkgrel instead
* Referenced https://wiki.archlinux.org/title/VCS_package_guidelines and
https://wiki.archlinux.org/title/AUR_submission_guidelines for these
changes
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 7 |
2 files changed, 6 insertions, 3 deletions
@@ -1,6 +1,6 @@ pkgbase = passage-git pkgdesc = A fork of password-store that uses age as backend. - pkgver = 1.7.4a0.r5.1262d30 + pkgver = 1.7.4a0.r526.4e4c5ae pkgrel = 1 url = https://github.com/FiloSottile/passage arch = any @@ -2,7 +2,7 @@ # Contributor: Jeremy Cantrell <jmcantrell at gmail dot com> pkgname=passage-git -pkgver=1.7.4a0.r5.1262d30 +pkgver=1.7.4a0.r526.4e4c5ae pkgrel=1 pkgdesc="A fork of password-store that uses age as backend." arch=('any') @@ -23,7 +23,10 @@ md5sums=('SKIP') pkgver() { cd "$srcdir/${pkgname%-git}" - printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')" + # Hard-coding the original password-store version used before passage fork + # Passage itself doesn't use tags so we go off revision number alone + # See: https://wiki.archlinux.org/title/VCS_package_guidelines + printf "1.7.4a0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)" } package() { |