summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Bellegarde2018-09-27 14:09:34 +0200
committerCédric Bellegarde2018-09-27 14:09:34 +0200
commit7865c56b3876bdb26e69f50592ee5db39cb6cf29 (patch)
tree55746544aa9720c32cd6e85e7cb51b9eeedfa25b
downloadaur-7865c56b3876bdb26e69f50592ee5db39cb6cf29.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD59
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f77b11b46049
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = passbook-git
+ pkgdesc = Password manager for GNOME
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Passbook
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = appstream-glib
+ depends = desktop-file-utils
+ depends = gobject-introspection
+ depends = gtk3
+ depends = itstool
+ depends = python-cairo
+ depends = python-gobject
+ provides = passbook
+ conflicts = passbook
+ source = git+https://gitlab.gnome.org/gnumdk/passbook.git
+ source = git+https://gitlab.gnome.org/gnumdk/passbook-po.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = passbook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53c3383443e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+pkgname='passbook-git'
+_gitname="${pkgname/-git}"
+pkgdesc='Password manager for GNOME'
+pkgver=0.1
+pkgrel=1
+url='https://wiki.gnome.org/Apps/Passbook'
+arch=('x86_64')
+license=('GPL3')
+makedepends=('git' 'meson' 'ninja')
+depends=(
+ 'appstream-glib' 'desktop-file-utils' 'gobject-introspection'
+ 'gtk3' 'itstool' 'python-cairo' 'python-gobject'
+)
+conflicts=("${_gitname}")
+provides=("${_gitname}")
+source=(
+ "git+https://gitlab.gnome.org/gnumdk/${_gitname}.git"
+ "git+https://gitlab.gnome.org/gnumdk/${_gitname}-po.git"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${_gitname}"
+
+ git describe --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_gitname}"
+
+ local -r submodules=(
+ 'passbook-po'
+ )
+
+ for module in "${submodules[@]}"; do
+ local submodule="subprojects/${module/passbook-/}"
+ git submodule init "${submodule}"
+ git config "submodule.${submodule}.url" "${srcdir}/${module}"
+ git submodule update "${submodule}"
+ done
+}
+
+build() {
+ cd "${_gitname}"
+
+ meson build --prefix=/usr
+}
+
+package() {
+ cd "${_gitname}"
+
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: