summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIcaro Perseo2016-10-20 19:45:51 -0500
committerIcaro Perseo2016-10-20 19:45:51 -0500
commita18ea8b1dca0b0f7768656b5295c20adc915501b (patch)
treeeca51e8f23ea84fb683c83d972fcb8f9d0cdb8dc
downloadaur-a18ea8b1dca0b0f7768656b5295c20adc915501b.tar.gz
First commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26117e0d8ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = passera
+ pkgdesc = A small tool to turn any entered passphrase into a strong secure password
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/icaroperseo/passera
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ source = passera::git+https://github.com/icaroperseo/passera.git
+ md5sums = SKIP
+
+pkgname = passera
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5884e16bce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
+
+pkgname=passera
+pkgver=0.1.5
+_commit=65dd4d4
+pkgrel=1
+pkgdesc="A small tool to turn any entered passphrase into a strong secure password"
+url="https://github.com/icaroperseo/passera"
+license=('GPL')
+arch=('i686' 'x86_64')
+makedepends=('go')
+source=("${pkgname}::git+https://github.com/icaroperseo/passera.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ git submodule update --init --recursive
+ export GOPATH=$PWD
+ go get github.com/howeyc/gopass
+ go get github.com/atotto/clipboard
+}
+
+build() {
+ cd ${pkgname}/src
+ patch -p2 -i gopass.patch
+ go build -o passera
+}
+
+package() {
+ cd ${pkgname}
+
+ install -Dm755 src/passera \
+ "${pkgdir}/usr/bin/passera"
+ install -Dm644 LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 cc=80 et: