summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcnmx2017-10-02 15:09:16 -0400
committerarcnmx2017-10-02 15:09:16 -0400
commite10c12c72a0a70926d8b0a0eee8a9ab0f857d843 (patch)
tree012bf21896dfb74b13bf9dbe4d719ed5454bab7c
downloadaur-e10c12c72a0a70926d8b0a0eee8a9ab0f857d843.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c19f14ff4edc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = passff-host
+ pkgdesc = PassFF native messaging host application for Firefox, Chromium, Chrome, Vivaldi
+ pkgver = 1.0.3linux
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python
+ source = https://github.com/passff/passff/releases/download/1.0.3linux/passff.py
+ source = https://github.com/passff/passff/releases/download/1.0.3linux/passff.json
+ md5sums = 5cd5c222defecc1bb83444dbef7fd26f
+ md5sums = 2512ca1ab6da1c8fcfdfc4e7dd5a2fe8
+
+pkgname = passff-host
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d5adc6f4939
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+/passff.json
+/passff.py
+/*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fa1a9808ff5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=passff-host
+pkgver=1.0.3linux
+pkgrel=1
+pkgdesc="PassFF native messaging host application for Firefox, Chromium, Chrome, Vivaldi"
+pkgurl=https://github.com/passff/passff
+license=(GPL2)
+depends=(python)
+arch=(i686 x86_64)
+source=(
+ https://github.com/passff/passff/releases/download/$pkgver/passff.py
+ https://github.com/passff/passff/releases/download/$pkgver/passff.json
+)
+
+_native_messaging=(
+ /etc/chromium/native-messaging-hosts
+ /etc/opt/chrome/native-messaging-hosts
+ /usr/lib/mozilla/native-messaging-hosts
+ /etc/vivaldi/native-messaging-hosts
+)
+
+_bindir="/usr/lib/passff"
+
+build() {
+ sed -i -e "s-PLACEHOLDER-$_bindir/passff.py-" "$srcdir/passff.json"
+}
+
+package() {
+ install -d "$pkgdir$_bindir"
+ install -m 0755 "$srcdir/passff.py" "$pkgdir$_bindir/"
+
+ for d in "${_native_messaging[@]}"; do
+ install -d "$pkgdir$d"
+ install -m 0644 "$srcdir/passff.json" "$pkgdir$d/"
+ done
+}
+
+# makepkg -g >> PKGBUILD
+md5sums=('5cd5c222defecc1bb83444dbef7fd26f'
+ '2512ca1ab6da1c8fcfdfc4e7dd5a2fe8')