summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2021-04-14 14:00:35 -0400
committerbinex-dsk2021-04-14 14:00:35 -0400
commit5bb822ed141323458ce57cd382ba1842335835ee (patch)
tree802c127607ae177eeb4bd66cb3f519e30d9aace1
parent1acbdafd24d23c2dd2788f805d64cab7692d4bb1 (diff)
downloadaur-5bb822ed141323458ce57cd382ba1842335835ee.tar.gz
2.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84db0a30474e..103bdeba8ee1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = passman++
pkgdesc = Incredibly simple and secure command-line password manager
- pkgver = 2.0.1
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/binex-dsk/passmanpp/
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = passman++
conflicts = passman-git
conflicts = passman++-devel
conflicts = passman++-lts
- source = https://github.com/binex-dsk/passmanpp/archive/2.0.1.tar.gz
- md5sums = 594a233a3219a6760e6e7614617d0fee
+ source = https://github.com/binex-dsk/passmanpp/archive/2.1.0.tar.gz
+ md5sums = c4129adfd5a1414967df049eba82c47d
pkgname = passman++
diff --git a/PKGBUILD b/PKGBUILD
index b48d3716e008..cd3ab58fe8a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,23 @@ pkgname='passman++'
pkgdesc='Incredibly simple and secure command-line password manager'
url="https://github.com/binex-dsk/$_pkgname/"
license=('GPL')
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.tar.gz")
-md5sums=('594a233a3219a6760e6e7614617d0fee')
+md5sums=('c4129adfd5a1414967df049eba82c47d')
provides=('passman')
conflicts=('passman-git' 'passman++-devel' 'passman++-lts')
depends=('botan' 'qt6-base')
arch=('x86_64')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- ./build.sh
+ cd $srcdir/$_pkgname-$pkgver
+ cmake -S . -B build -DCMAKE_INSTALL_BINDIR="/usr/bin/" -DCMAKE_INSTALL_DATAROOTDIR="/usr/share/"
+ cmake --build build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- install -Dm755 passman $pkgdir/usr/bin/passman
+ cd $srcdir/$_pkgname-$pkgver
+ cmake --build build --target install -- DESTDIR="$pkgdir"
}