summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2021-02-10 11:40:08 -0500
committerbinex-dsk2021-02-10 11:40:08 -0500
commita2406ea62f289dffd1bf50159224d5c4e0aa9886 (patch)
treea7c660968af3b3d259f02f49f8693b851e95b40f
parentb166b2cb6cfa2008ead8c102ca6dc1244984e376 (diff)
downloadaur-a2406ea62f289dffd1bf50159224d5c4e0aa9886.tar.gz
2.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63c2ad0bbffa..ffa3ed9e51b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = passman++
- pkgdesc = Incredibly simple and secure command-line password manager.
- pkgver = 1.4.0p
+ pkgdesc = Incredibly simple and secure command-line password manager
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/binex-dsk/passmanpp/
arch = x86_64
- license = BSD
+ license = GPL
depends = botan
depends = libsodium
- depends = qt5-base
- depends = ttf-hack
+ depends = qt6-base
+ optdepends = gnome-themes-extra: may be necessary for icons to work
+ optdepends = breeze: recommended theme to use for passman++
provides = passman
conflicts = passman-git
- source = https://github.com/binex-dsk/passmanpp/archive/1.4.0p.zip
- md5sums = 520d88de27f0c8d8ac46d1038b8375ce
+ conflicts = passman++-devel
+ conflicts = passman++-lts
+ source = https://github.com/binex-dsk/passmanpp/archive/2.0.0.tar.gz
+ md5sums = 7ce90dad4e3cb34d94fad7cd274ce57f
pkgname = passman++
diff --git a/PKGBUILD b/PKGBUILD
index f58dd9b7cab6..3e2ac2085277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,27 @@
_pkgname='passmanpp'
pkgname='passman++'
-pkgdesc='Incredibly simple and secure command-line password manager.'
+pkgdesc='Incredibly simple and secure command-line password manager'
url="https://github.com/binex-dsk/$_pkgname/"
-license=('BSD')
-pkgver=1.4.0p
+license=('GPL')
+pkgver=2.0.0
pkgrel=1
-source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.zip")
-md5sums=('520d88de27f0c8d8ac46d1038b8375ce')
+source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.tar.gz")
+md5sums=('7ce90dad4e3cb34d94fad7cd274ce57f')
provides=('passman')
-conflicts=('passman-git')
-depends=('botan' 'libsodium' 'qt5-base' 'ttf-hack')
+conflicts=('passman-git' 'passman++-devel' 'passman++-lts')
+depends=('botan' 'libsodium' 'qt6-base')
+optdepends=('gnome-themes-extra: may be necessary for icons to work'
+ 'breeze: recommended theme to use for passman++')
arch=('x86_64')
build() {
- cd "$srcdir/$_pkgname-$pkgver/src"
- qmake passman.pro
- make && make clean
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./build.sh
}
package() {
cd "$srcdir/$_pkgname-$pkgver"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- cd "src"
install -Dm755 passman $pkgdir/usr/bin/passman
}