summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2020-12-09 11:38:07 -0500
committerbinex-dsk2020-12-09 11:38:07 -0500
commit0181150f61a00facfcca957389abdd063cf2f4e2 (patch)
treeae6e88c4e24fb299336e9cc7d6fb9ab9b1afbf96
downloadaur-0181150f61a00facfcca957389abdd063cf2f4e2.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75bdb5098558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = passman++-devel
+ pkgdesc = Incredibly simple and secure command-line password manager - development/debug release
+ pkgver = 2.0.0rc1
+ pkgrel = 1
+ url = https://github.com/binex-dsk/passmanpp/
+ arch = x86_64
+ license = BSD
+ depends = botan
+ depends = libsodium
+ depends = qt5-base
+ depends = ttf-hack
+ provides = passman
+ conflicts = passman-git
+ conflicts = passman++
+ source = https://github.com/binex-dsk/passmanpp/archive/2.0.0rc1.zip
+ md5sums = fe58a3d3b51083ea7cc6c84399dfe264
+
+pkgname = passman++-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d852c555873
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carson Rueter <roachh@protonmail.com>
+
+_pkgname='passmanpp'
+pkgname='passman++-devel'
+pkgdesc='Incredibly simple and secure command-line password manager - development/debug release'
+url="https://github.com/binex-dsk/$_pkgname/"
+license=('BSD')
+pkgver=2.0.0rc1
+pkgrel=1
+source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.zip")
+md5sums=('fe58a3d3b51083ea7cc6c84399dfe264')
+provides=('passman')
+conflicts=('passman-git' 'passman++')
+depends=('botan' 'libsodium' 'qt5-base' 'ttf-hack')
+arch=('x86_64')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ cmake -Wno-dev
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 passman $pkgdir/usr/bin/passman
+}
+