summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2021-02-10 11:40:40 -0500
committerbinex-dsk2021-02-10 11:40:40 -0500
commitb445c353980b1d62a4f60b47707a091206f94c64 (patch)
treeb5c8fd851fe68c9c5c2b5945549ba093fee7e828
parent3c5ce184412c1a17dbf8624f9780403f756f259f (diff)
downloadaur-b445c353980b1d62a4f60b47707a091206f94c64.tar.gz
2.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e60283561ee8..d637b72f48bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = passman++-devel
pkgdesc = Incredibly simple and secure command-line password manager - development/debug release
- pkgver = 2.0.0rc6
- pkgrel = 2
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/binex-dsk/passmanpp/
arch = x86_64
- license = BSD
+ license = GPL
depends = botan
depends = libsodium
depends = qt6-base
@@ -13,8 +13,9 @@ pkgbase = passman++-devel
provides = passman
conflicts = passman-git
conflicts = passman++
- source = https://github.com/binex-dsk/passmanpp/archive/2.0.0rc6.zip
- md5sums = 9c7b8297b10888a9a28bc11207e004dc
+ conflicts = passman++-lts
+ source = https://github.com/binex-dsk/passmanpp/archive/2.0.0.tar.gz
+ md5sums = 7ce90dad4e3cb34d94fad7cd274ce57f
pkgname = passman++-devel
diff --git a/PKGBUILD b/PKGBUILD
index 4f1009d0f32e..3fd18204ee09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ _pkgname='passmanpp'
pkgname='passman++-devel'
pkgdesc='Incredibly simple and secure command-line password manager - development/debug release'
url="https://github.com/binex-dsk/$_pkgname/"
-license=('BSD')
-pkgver=2.0.0rc6
-pkgrel=2
-source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.zip")
-md5sums=('9c7b8297b10888a9a28bc11207e004dc')
+license=('GPL')
+pkgver=2.0.0
+pkgrel=1
+source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.tar.gz")
+md5sums=('7ce90dad4e3cb34d94fad7cd274ce57f')
provides=('passman')
-conflicts=('passman-git' 'passman++')
+conflicts=('passman-git' 'passman++' 'passman++-lts')
depends=('botan' 'libsodium' 'qt6-base')
optdepends=('gnome-themes-extra: may be necessary for icons to work'
'breeze: recommended theme to use for passman++')
@@ -23,7 +23,6 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm755 passman $pkgdir/usr/bin/passman
}