summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2021-04-14 14:00:13 -0400
committerbinex-dsk2021-04-14 14:00:13 -0400
commitbc5e7bcb214c096f0d95adefb5ace18d4fda623d (patch)
tree094a9fde9be0359752f84f2ab35b36bbd5214d93
parentf52b70dcfcc075975be4a849844178cee7e54a85 (diff)
downloadaur-bc5e7bcb214c096f0d95adefb5ace18d4fda623d.tar.gz
2.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0762f2c788..0a7393dca501 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = passman++-devel
- pkgdesc = Incredibly simple and secure command-line password manager - development/debug release
- pkgver = 2.0.1
+ pkgdesc = Incredibly simple and secure command-line password manager - development releases
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/binex-dsk/passmanpp/
arch = x86_64
@@ -11,8 +11,8 @@ pkgbase = passman++-devel
conflicts = passman-git
conflicts = passman++
conflicts = passman++-lts
- source = https://github.com/binex-dsk/passmanpp/archive/2.0.1.tar.gz
- md5sums = 594a233a3219a6760e6e7614617d0fee
+ source = https://github.com/binex-dsk/passmanpp/archive/2.1.0.tar.gz
+ md5sums = c4129adfd5a1414967df049eba82c47d
pkgname = passman++-devel
diff --git a/PKGBUILD b/PKGBUILD
index 2b41dd3e9ed0..5974da655f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
_pkgname='passmanpp'
pkgname='passman++-devel'
-pkgdesc='Incredibly simple and secure command-line password manager - development/debug release'
+pkgdesc='Incredibly simple and secure command-line password manager - development releases'
url="https://github.com/binex-dsk/$_pkgname/"
license=('GPL')
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.tar.gz")
-md5sums=('594a233a3219a6760e6e7614617d0fee')
+md5sums=('c4129adfd5a1414967df049eba82c47d')
provides=('passman')
conflicts=('passman-git' 'passman++' 'passman++-lts')
depends=('botan' 'qt6-base')
arch=('x86_64')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- ./build.sh
+ cd $srcdir/$_pkgname-$pkgver
+ cmake -S . -B build -DCMAKE_INSTALL_BINDIR="/usr/bin/" -DCMAKE_INSTALL_DATAROOTDIR="/usr/share/"
+ cmake --build build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- install -Dm755 passman $pkgdir/usr/bin/passman
+ cd $srcdir/$_pkgname-$pkgver
+ cmake --build build --target install -- DESTDIR="$pkgdir"
}