summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbinex-dsk2021-02-10 11:39:37 -0500
committerbinex-dsk2021-02-10 11:39:37 -0500
commit2df251f3848dd20b998fdab02c40552c15577ed4 (patch)
tree68973093c760b9777b4efc56cef180745fb3c0ee
downloadaur-2df251f3848dd20b998fdab02c40552c15577ed4.tar.gz
initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f496de5056ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = passman++-lts
+ pkgdesc = Incredibly simple and secure command-line password manager. - LTS releases
+ pkgver = 1.4.0p
+ pkgrel = 1
+ url = https://github.com/binex-dsk/passmanpp/
+ arch = x86_64
+ license = BSD
+ depends = botan
+ depends = libsodium
+ depends = qt5-base
+ depends = ttf-hack
+ provides = passman
+ conflicts = passman-git
+ conflicts = passman++-devel
+ conflicts = passman++
+ source = https://github.com/binex-dsk/passmanpp/archive/1.4.0p.tar.gz
+ md5sums = 520d88de27f0c8d8ac46d1038b8375ce
+
+pkgname = passman++-lts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93456d431949
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carson Rueter <roachh@protonmail.com>
+
+_pkgname='passmanpp'
+pkgname='passman++-lts'
+pkgdesc='Incredibly simple and secure command-line password manager. - LTS releases'
+url="https://github.com/binex-dsk/$_pkgname/"
+license=('BSD')
+pkgver=1.4.0p
+pkgrel=1
+source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.tar.gz")
+md5sums=('520d88de27f0c8d8ac46d1038b8375ce')
+provides=('passman')
+conflicts=('passman-git' 'passman++-devel' 'passman++')
+depends=('botan' 'libsodium' 'qt5-base' 'ttf-hack')
+arch=('x86_64')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver/src"
+ qmake passman.pro
+ make && make clean
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "src"
+ install -Dm755 passman $pkgdir/usr/bin/passman
+}