summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspergmoment2020-06-30 23:07:34 -0400
committerspergmoment2020-06-30 23:07:34 -0400
commitf5a8250d60b8d671911402b143a8e8e766c487eb (patch)
tree688542ed9ada3f7e4ad028a741ca940a1fe7a297
downloadaur-f5a8250d60b8d671911402b143a8e8e766c487eb.tar.gz
stuff
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ced241aff21b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = passman
+ pkgdesc = Super-secure, easy-to-use password manager.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/binex-dsk/passman-aur
+ arch = any
+ license = GPL3
+ depends = python3
+ depends = python-sqlalchemy
+ provides = passman
+ source = git+https://github.com/binex-dsk/passman-aur.git
+ md5sums = SKIP
+
+pkgname = passman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48889ea98628
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Carson Rueter <bottomtext97@gmail.com>
+pkgname='passman'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Super-secure, easy-to-use password manager."
+arch=('any')
+url="https://github.com/binex-dsk/passman-aur"
+license=('GPL3')
+provides=('passman')
+depends=('python3' 'python-sqlalchemy')
+source=("git+https://github.com/binex-dsk/passman-aur.git")
+md5sums=('SKIP')
+
+package() {
+ if [ -d ~/.config/passman != 0 ]; then mkdir ~/.config/passman; fi
+ install -Dm755 "${srcdir}/passman-aur/passman" "${pkgdir}/usr/bin/passman"
+ install -Dm755 "${srcdir}/passman-aur/passman.pyc" "${pkgdir}${HOME}/.config/passman/passman.pyc"
+}