summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorugla2022-05-08 17:26:43 +0200
committerugla2022-05-08 17:26:43 +0200
commit99798f5f5a4c37a63d17e96074895e6b2c6d4228 (patch)
treeed14e696faad13299d3efa8a1cc01d611e0abe78
parent78c4f621d0e3a7c530f45b2de016e96893a5c404 (diff)
downloadaur-99798f5f5a4c37a63d17e96074895e6b2c6d4228.tar.gz
1.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 5 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed99f38ad4bb..442c0d535472 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = passphrase
pkgdesc = Small, simple passphrase generator, written in Zig
- pkgver = 1.3
+ pkgver = 1.4
pkgrel = 1
url = https://git.sr.ht/~alva/passphrase
arch = any
license = MIT
makedepends = zig>=0.9.1
makedepends = git
- source = git+https://git.sr.ht/~alva/passphrase#tag=1.3
- source = git+https://github.com/jecolon/ziglyph.git
- sha256sums = SKIP
+ source = git+https://git.sr.ht/~alva/passphrase#tag=1.4
sha256sums = SKIP
pkgname = passphrase
diff --git a/PKGBUILD b/PKGBUILD
index 5cef1ca47e35..7022fa3807da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
# Maintainer: ugla <ugla at u8 dot is>
pkgname=passphrase
pkgrel=1
-pkgver=1.3
+pkgver=1.4
pkgdesc="Small, simple passphrase generator, written in Zig"
arch=('any')
url="https://git.sr.ht/~alva/${pkgname}"
license=('MIT')
makedepends=('zig>=0.9.1' 'git')
-source=("git+https://git.sr.ht/~alva/${pkgname}#tag=${pkgver}" "git+https://github.com/jecolon/ziglyph.git")
-sha256sums=('SKIP' 'SKIP')
+source=("git+https://git.sr.ht/~alva/${pkgname}#tag=${pkgver}")
+sha256sums=('SKIP')
check() {
cd "${srcdir}/${pkgname}"
zig build test
}
-prepare() {
- cd "${srcdir}/${pkgname}"
- git submodule update --init --recursive
- git config submodule.ziglyph.url "${srcdir}/ziglyph"
- git submodule update
-}
-
package() {
cd "${srcdir}/${pkgname}"
zig build install -Drelease-fast --prefix "${pkgdir}/usr"