summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrany2021-11-18 23:05:57 +0200
committerrany2021-11-18 23:05:57 +0200
commit6a6775e0891a29da0557cbcc637356d001746ba8 (patch)
tree3004c07e6fb02f42deffc482d4873f021aeb07f3
parentb1be3854a172921319e8728dbfe766ea7959afbc (diff)
downloadaur-6a6775e0891a29da0557cbcc637356d001746ba8.tar.gz
Fix issue with my -git package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3b317348779..3d2c0e739689 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = passphraseme-git
pkgdesc = A quick and simple cryptographically secure script to generate high entropy passphrases using EFF's wordlists
pkgver = 0.1.4
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/micahflee/passphraseme
arch = any
license = GPL3
@@ -11,4 +11,3 @@ pkgbase = passphraseme-git
sha1sums = SKIP
pkgname = passphraseme-git
-
diff --git a/PKGBUILD b/PKGBUILD
index cdbf3c6b38b3..83883358d7a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=passphraseme-git
-pkgrel=3
+pkgrel=4
pkgver=0.1.4
pkgdesc="A quick and simple cryptographically secure script to generate high entropy passphrases using EFF's wordlists"
url="https://github.com/micahflee/passphraseme"
@@ -9,6 +9,10 @@ makedepends=('git')
depends=('python')
source=("git+https://github.com/micahflee/passphraseme.git")
sha1sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
cd "passphraseme"
sed -i passphraseme/__init__.py -e '1 s/^\#!\/usr\/bin\/env python3$/\#!\/usr\/bin\/python3/g'