summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrany2020-11-07 13:30:37 +0200
committerrany2020-11-07 13:30:37 +0200
commit8f2c69a74c1e575745536fd4ae001559e4f6862f (patch)
tree7fad4a6783c33ba07d010e47bd99d90873e6aff3
downloadaur-8f2c69a74c1e575745536fd4ae001559e4f6862f.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a56b5b237df4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = passphraseme-git
+ pkgdesc = A quick and simple cryptographically secure script to generate high entropy passphrases using EFF's wordlists
+ pkgver = 0.1.4
+ pkgrel = 0
+ url = https://github.com/micahflee/passphraseme
+ arch = any
+ license = GPL3
+ depends = gtk3
+ depends = libappindicator-gtk3
+ depends = python
+ depends = openvpn
+ source = git+https://github.com/micahflee/passphraseme.git#commit=cebb21bfe552c3edcb96dbbac750971faa5866c9
+ sha1sums = SKIP
+
+pkgname = passphraseme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bfc5c1354ee5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+*.pkg.*
+src/
+passphraseme/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..787292bdddc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=passphraseme-git
+pkgrel=0
+pkgver=0.1.4
+_commit=cebb21bfe552c3edcb96dbbac750971faa5866c9
+pkgdesc="A quick and simple cryptographically secure script to generate high entropy passphrases using EFF's wordlists"
+url="https://github.com/micahflee/passphraseme"
+arch=('any')
+license=('GPL3')
+depends=(
+ 'gtk3'
+ 'libappindicator-gtk3'
+ 'python'
+ 'openvpn'
+)
+source=(
+ "git+https://github.com/micahflee/passphraseme.git#commit=${_commit}"
+)
+sha1sums=(
+ 'SKIP'
+)
+build() {
+ cd "passphraseme"
+ sed -i passphraseme/__init__.py -e '1 s/^\#!\/usr\/bin\/env python3$/\#!\/usr\/bin\/python3/g'
+ sed -i passphraseme/__init__.py -e 's/os.path.dirname(os.path.abspath(/os.path.dirname(os.path.realpath(/g'
+}
+package() {
+ cd "passphraseme"
+ mkdir -p "${pkgdir}/usr/share/passphraseme" "${pkgdir}/usr/bin"
+ cp -r passphraseme/__init__.py passphraseme/wordlists/ "${pkgdir}/usr/share/passphraseme"
+ ln -s /usr/share/passphraseme/__init__.py "${pkgdir}/usr/bin/passphraseme"
+}