summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-08-22 19:12:29 +0300
committerorhun2020-08-22 19:12:29 +0300
commitc34a0bbe1a61e7bb4117414919d5a49ae1174aee (patch)
tree1ba4231e0385b947d6e554afdbd4fce7f5d6c09e
downloadaur-c34a0bbe1a61e7bb4117414919d5a49ae1174aee.tar.gz
Initial upload: passwall-server 1.1.2-1
Add passwall-server
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7857f19e4c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = passwall-server
+ pkgdesc = Core backend infrastructure of the PassWall platform
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/passwall/passwall-server
+ arch = x86_64
+ license = AGPL3
+ makedepends = go
+ depends = git
+ source = git+https://github.com/passwall/passwall-server
+ sha256sums = SKIP
+
+pkgname = passwall-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35a7e6e1d1b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=passwall-server
+pkgdesc="Core backend infrastructure of the PassWall platform"
+pkgver=1.1.2
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/passwall/passwall-server"
+license=('AGPL3')
+depends=('git')
+makedepends=('go')
+source=("git+$url")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname/cmd/$pkgname"
+ go get -d ./...
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o "$pkgname" .
+}
+
+package() {
+ cd "$srcdir/$pkgname/cmd/$pkgname"
+ install -Dm 755 "$pkgname" "$pkgdir/usr/local/bin/$pkgname"
+}