summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkurdy2021-05-16 18:03:48 +0200
committerkurdy2021-05-16 18:03:48 +0200
commit97b3f28f676f9639eb84befb4f44a2ac35d25656 (patch)
tree05d7ecfa2a00985a50cf8339cb8621fa99617564
downloadaur-97b3f28f676f9639eb84befb4f44a2ac35d25656.tar.gz
Initial version of AUR package.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1129fc9f6ac5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = passwd-gen-cli
+ pkgdesc = Command line application to generate passwords or a phrase composed of several words. It is possible to use one or more collections as source to create them.
+ pkgver = 1.0.0rc.1
+ pkgrel = 1
+ url = https://bitbucket.org/kurdy/passwd-gen-cli/src/master/
+ arch = any
+ license = MIT
+ makedepends = dart
+ provides = passwd_gen
+ conflicts = passwd_gen
+ source = passwd-gen-cli-v1.0.0rc.1.tar.gz::https://bitbucket.org/kurdy/passwd-gen-cli/get/v1.0.0-rc.1.tar.gz
+ sha256sums = 41ca9f19b171851be53d76ee84a2afb3925d36b333194213780fac51432081e9
+
+pkgname = passwd-gen-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc499b1a32e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer Willy Reinhardt <dev@kurdy.ch>
+
+pkgname=passwd-gen-cli
+pkgver=1.0.0rc.1
+pkgrel=1
+pkgdesc="Command line application to generate passwords or a phrase composed of several words. It is possible to use one or more collections as source to create them."
+url="https://bitbucket.org/kurdy/passwd-gen-cli/src/master/"
+license=('MIT')
+source=("${pkgname}-v${pkgver}.tar.gz::https://bitbucket.org/kurdy/passwd-gen-cli/get/v1.0.0-rc.1.tar.gz")
+sha256sums=('41ca9f19b171851be53d76ee84a2afb3925d36b333194213780fac51432081e9')
+arch=('any')
+_srcpath='kurdy-passwd-gen-cli-f00496002935'
+makedepends=('dart')
+checkdepends=()
+provides=('passwd_gen')
+conflicts=('passwd_gen')
+
+check() {
+ cd ${_srcpath}
+ dart run test -n 'Command line tests'
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd ${_srcpath}
+ mkdir -p ${pkgdir}/usr/bin/
+ dart2native ./bin/passwd_gen_cli.dart -o ${pkgdir}/usr/bin/passwd_gen
+}