summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Obermaier2019-06-26 15:31:40 +0200
committerHolger Obermaier2019-06-26 15:31:40 +0200
commit739ba246c0792472634aa8a480107d504ad41251 (patch)
tree01c39e471be67650082101a5ee4004095f27ec09
parent3537ca049c8bd50bbe48c2c89661a27d4a90db99 (diff)
downloadaur-739ba246c0792472634aa8a480107d504ad41251.tar.gz
Changed to sha255 checksums
-rw-r--r--PKGBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f67658db9071..6f6c6889f58f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
pkgname="password-gorilla"
realpkgname="gorilla"
pkgver="1.5.3.7"
-pkgrel=5
+pkgrel=6
pkgdesc="A cross-platform password manager."
arch=('x86_64')
url="https://github.com/zdia/gorilla/wiki/"
license=('GPL2')
-source=( "http://gorilla.dp100.com/downloads/${realpkgname}1537_64.bin"
- "http://gorilla.dp100.com/downloads/${realpkgname}-1.5.3.7.zip" )
-md5sums=( 'f41395230978380820b8e2cc9bd5a708'
- 'f5ed6b1994401d2204d3fed2e0e5d938' )
+source=(
+ "http://gorilla.dp100.com/downloads/${realpkgname}1537_64.bin"
+ "http://gorilla.dp100.com/downloads/${realpkgname}-1.5.3.7.zip"
+)
+sha256sums=(
+ '19f4cfa9f76a04d6c5427b0049f8e2d5833367676b71d12f2c0205c0483739a6'
+ '747483e3d9cc7dfac48be0445c5f606e8d18a01dd91edbcee9d361c39bfec951'
+)
options=( '!strip' )
package() {
- # directory structur
+ # target directory structur
local bin_dir="${pkgdir}/usr/bin"
local icon_dir="${pkgdir}/usr/share/icons/hicolor"
local icon48x48_dir="${icon_dir}/48x48/apps"
@@ -25,21 +29,24 @@ package() {
local menu_dir="${pkgdir}/usr/share/menu"
local man_dir="${pkgdir}/usr/share/man/man1"
+ # source directory structure
+ local srcdir_deb="${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data"
+
# binary
install -D --preserve-timestamps --verbose --mode=u=rwx,go=rx "${srcdir}/gorilla1537_64.bin" "${bin_dir}/password-gorilla"
# icons
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/16x16.password-gorilla.png" "${icon16x16_dir}/password-gorilla.png"
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/32x32.password-gorilla.png" "${icon32x32_dir}/password-gorilla.png"
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/48x48.password-gorilla.png" "${icon48x48_dir}/password-gorilla.png"
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.xpm" "${pixmaps_dir}/password-gorilla.xpm"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/16x16.password-gorilla.png" "${icon16x16_dir}/password-gorilla.png"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/32x32.password-gorilla.png" "${icon32x32_dir}/password-gorilla.png"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/48x48.password-gorilla.png" "${icon48x48_dir}/password-gorilla.png"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/password-gorilla.xpm" "${pixmaps_dir}/password-gorilla.xpm"
# desktop file
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.desktop" "${desktop_dir}/password-gorilla.desktop"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/password-gorilla.desktop" "${desktop_dir}/password-gorilla.desktop"
# menu file
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.menu" "${menu_dir}/password-gorilla.menu"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/password-gorilla.menu" "${menu_dir}/password-gorilla.menu"
# man file
- install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.1" "${man_dir}/password-gorilla.1"
+ install -D --preserve-timestamps --verbose "${srcdir_deb}/password-gorilla.1" "${man_dir}/password-gorilla.1"
}