summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Obermaier2015-11-14 19:04:53 +0100
committerHolger Obermaier2015-11-14 19:04:53 +0100
commit86ff0cf2765d039322befd5ff5f3b150da2d0339 (patch)
tree98514118b3990a416c4d8c8fb4bfb90a1a3ba0a3
parentd2bee3cca2111704a55c583f70027ffba4cab6de (diff)
downloadaur-86ff0cf2765d039322befd5ff5f3b150da2d0339.tar.gz
Add menu file
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e2036ed0cf3..d05114ddaca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="password-gorilla"
realpkgname="gorilla"
pkgver="1.5.3.7"
-pkgrel=3
+pkgrel=4
pkgdesc="A cross-platform password manager."
arch=('x86_64')
url="https://github.com/zdia/gorilla/wiki/"
@@ -22,6 +22,7 @@ package() {
local icon16x16_dir="${icon_dir}/16x16/apps"
local pixmaps_dir="${pkgdir}/usr/share/pixmaps"
local desktop_dir="${pkgdir}/usr/share/applications"
+ local menu_dir="${pkgdir}/usr/share/menu"
local man_dir="${pkgdir}/usr/share/man/man1"
# binary
@@ -31,10 +32,14 @@ package() {
install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/16x16.password-gorilla.png" "${icon16x16_dir}/password-gorilla.png"
install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/32x32.password-gorilla.png" "${icon32x32_dir}/password-gorilla.png"
install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/48x48.password-gorilla.png" "${icon48x48_dir}/password-gorilla.png"
+ install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.xpm" "${pixmaps_dir}/password-gorilla.xpm"
# desktop file
install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.desktop" "${desktop_dir}/password-gorilla.desktop"
+ # menu file
+ install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.menu" "${menu_dir}/password-gorilla.menu"
+
# man file
install -D --preserve-timestamps --verbose "${srcdir}/${realpkgname}-${pkgver}/utilities/make-deb.data/password-gorilla.1" "${man_dir}/password-gorilla.1"
}