summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDudemanguy2020-07-04 14:11:24 -0500
committerDudemanguy2020-07-04 14:11:24 -0500
commitcf49e2f3ee6e814a3f378870e0f744f6efaf3fc8 (patch)
treedcf0fa77a8524b867d4172af25ecd9538bd85745
downloadaur-cf49e2f3ee6e814a3f378870e0f744f6efaf3fc8.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd562a137080
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = password-sanity-git
+ pkgdesc = A simple, python program for securely managing passwords through the command line
+ pkgver = 0.3_6_g7cedd8d
+ pkgrel = 1
+ url = https://github.com/Dudemanguy/password-sanity
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = python-gnupg
+ source = password-sanity::git+https://github.com/Dudemanguy/password-sanity.git
+ sha512sums = SKIP
+
+pkgname = password-sanity-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..327d6e310af9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Mantainer: Dudemanguy <random342@airmail.cc>
+pkgname=password-sanity-git
+_pkgname=password-sanity
+pkgver=0.3_6_g7cedd8d
+pkgrel=1
+license=("GPL3")
+pkgdesc="A simple, python program for securely managing passwords through the command line"
+depends=("python" "python-gnupg")
+arch=("x86_64")
+url="https://github.com/Dudemanguy/password-sanity"
+source=("${_pkgname}::git+https://github.com/Dudemanguy/password-sanity.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(git describe --tags)" | sed s/-/_/g
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" python setup.py install --root="${pkgdir}" --optimize=1
+}