summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-10-03 15:03:16 +0200
committerMartchus2023-10-03 15:03:16 +0200
commit7258368dc90b3186ec3ace284f1e6ef61ccea6ab (patch)
treef9e3bb404215b85caf3dcf188291f62e5ed9cea9
parent805578c01c5b20626e9a2045ea099df4340b9d1b (diff)
downloadaur-passwordfile-git.tar.gz
Sync with PKGBUILDs version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66383f74b2d3..d7bfbf1fe0cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,8 @@ pkgbase = passwordfile-git
makedepends = git
makedepends = ninja
depends = libc++utilities-git.so
- depends = openssl
- depends = zlib
+ depends = libcrypto.so
+ depends = libz.so
optdepends = passwordfile-doc: API documentation
provides = libpasswordfile-git.so
source = passwordfile::git+https://github.com/Martchus/passwordfile.git
diff --git a/PKGBUILD b/PKGBUILD
index ba22e4be2882..75c6d500a728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='C++ library to read/write passwords from/to encrypted files using AES-256-CBC via OpenSSL'
license=('GPL')
-depends=('libc++utilities-git.so' 'openssl' 'zlib')
+depends=('libc++utilities-git.so' 'libcrypto.so' 'libz.so')
optdepends=("$_name-doc: API documentation")
makedepends=('cmake' 'git' 'ninja')
checkdepends=('cppunit')