summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-02-05 09:31:21 +0100
committerMartchus2020-02-05 09:31:21 +0100
commit3f45dc9ad2afe4baca66658491a0bdd2aeb767b6 (patch)
treedc2202c79af13d1cccfaf54b23489d4c3b070984
parentee813dd87180b13e9e39566672aa2b26209ada32 (diff)
downloadaur-3f45dc9ad2afe4baca66658491a0bdd2aeb767b6.tar.gz
Make libs installable alongside the regular version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65c38c3b6029..278c6ccca981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = passwordfile-git
pkgdesc = C++ library to read/write passwords from/to encrypted files using AES-256-CBC via OpenSSL
- pkgver = 45.2b28fbcc66
- pkgrel = 1
+ pkgver = 105.b1a55de
+ pkgrel = 2
url = https://github.com/Martchus/passwordfile
arch = i686
arch = x86_64
@@ -15,7 +15,6 @@ pkgbase = passwordfile-git
depends = c++utilities-git
depends = openssl
optdepends = passwordfile-doc: API documentation
- conflicts = passwordfile
source = passwordfile::git://github.com/Martchus/passwordfile.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 85f1d8045b14..9e0477444f73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_reponame=passwordfile
pkgname=passwordfile-git
_name=${pkgname%-git}
-pkgver=45.2b28fbcc66
-pkgrel=1
+pkgver=105.b1a55de
+pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='C++ library to read/write passwords from/to encrypted files using AES-256-CBC via OpenSSL'
license=('GPL')
@@ -16,7 +16,7 @@ optdepends=("$_name-doc: API documentation")
makedepends=('cmake' 'git')
checkdepends=('cppunit')
#provides=("${_name}")
-conflicts=("${_name}")
+#conflicts=("${_name}")
install=
url="https://github.com/Martchus/${_reponame}"
source=("${_reponame}::${MARTCHUS_GIT_URL_PREFIX:-git://github.com/Martchus}/${_reponame}.git")
@@ -32,6 +32,9 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DCONFIGURATION_NAME:STRING='git' \
+ -DCONFIGURATION_PACKAGE_SUFFIX:STRING='-git' \
+ -DCONFIGURATION_TARGET_SUFFIX:STRING='git' \
-DBUILD_SHARED_LIBS:BOOL=ON \
.
make