summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schnaidt2016-07-24 19:11:53 +0200
committerAlexander Schnaidt2016-07-24 19:11:53 +0200
commit95455721a6f6e6c0457ee4dc0ce2f956ce3083a8 (patch)
tree93e7b69d96c222e9cbc5d752a10cb7c2ffbab2cd
parent577e13fd3ff76b7e73964e879fbd7d4bc913dce6 (diff)
downloadaur-95455721a6f6e6c0457ee4dc0ce2f956ce3083a8.tar.gz
passwordsafe: update for 0.99BETA
-rw-r--r--.SRCINFO13
-rw-r--r--0001-Fixed-broken-Linux-Makefile-based-build.patch107
-rw-r--r--PKGBUILD15
-rw-r--r--passwordsafe.install12
4 files changed, 9 insertions, 138 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3840c4bceed..8e02df47d01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Mar 10 16:49:40 UTC 2016
+# Sun Jul 24 17:10:59 UTC 2016
pkgbase = passwordsafe
pkgdesc = Simple & Secure Password Management
- pkgver = 0.98.1BETA
+ pkgver = 0.99BETA
pkgrel = 1
url = https://pwsafe.org/
- install = passwordsafe.install
arch = i686
arch = x86_64
license = Artistic2.0
@@ -21,12 +20,10 @@ pkgbase = passwordsafe
conflicts = passwordsafe-git
conflicts = pwsafe
conflicts = pwsafe-gui
- source = https://github.com/pwsafe/pwsafe/releases/download/0.98.1BETA/pwsafe-0.98.1BETA-src.tgz
- source = https://github.com/pwsafe/pwsafe/releases/download/0.98.1BETA/pwsafe-0.98.1BETA-src.tgz.sig
- source = 0001-Fixed-broken-Linux-Makefile-based-build.patch
- sha1sums = 505f0d24376ae0dc886958869ea8e2f2e14d85ca
+ source = https://github.com/pwsafe/pwsafe/releases/download/0.99BETA/pwsafe-0.99BETA-src.tgz
+ source = https://github.com/pwsafe/pwsafe/releases/download/0.99BETA/pwsafe-0.99BETA-src.tgz.sig
+ sha1sums = 3b736247712c5054e511b8946e7b93eb31eaf287
sha1sums = SKIP
- sha1sums = 8dcb2d5b9d7f8eb58d7f6b54b23e2a4eaa2b981c
pkgname = passwordsafe
diff --git a/0001-Fixed-broken-Linux-Makefile-based-build.patch b/0001-Fixed-broken-Linux-Makefile-based-build.patch
deleted file mode 100644
index 7ddd73a2498..00000000000
--- a/0001-Fixed-broken-Linux-Makefile-based-build.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From eea4ef611110f34f184b8d49d1832beb2e0f5cec Mon Sep 17 00:00:00 2001
-From: ronys <ronys@pwsafe.org>
-Date: Tue, 8 Mar 2016 22:11:35 +0200
-Subject: [PATCH] Fixed broken Linux Makefile-based build
-
-Which required supporting point revisions correctly.
----
- Makefile.linux | 3 ++-
- src/ui/wxWidgets/Makefile | 10 +++++++---
- src/ui/wxWidgets/about.cpp | 2 +-
- src/ui/wxWidgets/pwsafeapp.cpp | 2 --
- src/ui/wxWidgets/version.cpp | 18 ++++++++++++------
- 5 files changed, 22 insertions(+), 13 deletions(-)
-
-diff --git a/Makefile.linux b/Makefile.linux
-index 5762a47..6acf069 100644
---- a/Makefile.linux
-+++ b/Makefile.linux
-@@ -2,7 +2,8 @@
- # Toplevel Makefile for Linux build of PasswordSafe
-
- export VER_MAJOR := 0
--export VER_MINOR := 98.1
-+export VER_MINOR := 98
-+export VER_REV := 1
- export VER_SPECIAL := BETA
-
- # Since we use wxWidgets 3.x, while many distros still provide 2.8
-diff --git a/src/ui/wxWidgets/Makefile b/src/ui/wxWidgets/Makefile
-index b8e4ed5..9bd3cd8 100644
---- a/src/ui/wxWidgets/Makefile
-+++ b/src/ui/wxWidgets/Makefile
-@@ -240,9 +240,13 @@ $(DEPDIR)/%.d: %.cpp version.h
- $(RM) $@.$$$$
-
- version.h: always
-- @../../../Misc/mkversion.pl MAJOR=$(VER_MAJOR) MINOR=$(VER_MINOR) SPECIAL=$(VER_SPECIAL) \
-- version.in $@
--
-+ifdef VER_REV
-+ @../../../Misc/mkversion.pl MAJOR=$(VER_MAJOR) MINOR=$(VER_MINOR) REV=$(VER_REV) \
-+ SPECIAL=$(VER_SPECIAL) version.in $@
-+else
-+ @../../../Misc/mkversion.pl MAJOR=$(VER_MAJOR) MINOR=$(VER_MINOR) \
-+ SPECIAL=$(VER_SPECIAL) version.in $@
-+endif
- -include $(SOURCES:%.cpp=$(DEPDIR)/%.d)
-
-
-diff --git a/src/ui/wxWidgets/about.cpp b/src/ui/wxWidgets/about.cpp
-index 6742a39..a101136 100644
---- a/src/ui/wxWidgets/about.cpp
-+++ b/src/ui/wxWidgets/about.cpp
-@@ -328,7 +328,7 @@ void CAbout::CheckNewVersion()
- }
- stringT latest;
- if (status == CheckVersion::UP2DATE) {
-- CheckVersion cv(MAJORVERSION, MINORVERSION, 0);
-+ CheckVersion cv(MAJORVERSION, MINORVERSION, REVISION);
- status = cv.CheckLatestVersion(latest_xml, latest);
- }
- m_newVerStatus->Clear();
-diff --git a/src/ui/wxWidgets/pwsafeapp.cpp b/src/ui/wxWidgets/pwsafeapp.cpp
-index fcf17f4..27c9e95 100644
---- a/src/ui/wxWidgets/pwsafeapp.cpp
-+++ b/src/ui/wxWidgets/pwsafeapp.cpp
-@@ -274,8 +274,6 @@ bool PwsafeApp::OnInit()
- wxFileSystem::AddHandler(new wxArchiveFSHandler);
-
- SetAppName(pwsafeAppName);
-- m_core.SetApplicationNameAndVersion(tostdstring(pwsafeAppName),
-- DWORD((MINORVERSION << 16) | MAJORVERSION));
- PWSprefs::SetReporter(&aReporter);
- PWScore::SetReporter(&aReporter);
- PWScore::SetAsker(&anAsker);
-diff --git a/src/ui/wxWidgets/version.cpp b/src/ui/wxWidgets/version.cpp
-index cc9e726..d3af576 100644
---- a/src/ui/wxWidgets/version.cpp
-+++ b/src/ui/wxWidgets/version.cpp
-@@ -17,12 +17,18 @@
- #endif
-
- const wxString pwsafeAppName(APPNAME);
--#ifndef _DEBUG
--const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d (%ls) %ls")),
-- MAJORVERSION, MINORVERSION,
-- _T(VCS_VERSION), SPECIALBUILD);
-+#ifdef _DEBUG
-+const wchar_t *debstr = L"[debug] ";
-+#else
-+const wchar_t *debstr = L"";
-+#endif
-+
-+#if defined(REVISION) && (REVISION != 0)
-+const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d.%d (%ls) %ls%ls")),
-+ MAJORVERSION, MINORVERSION, REVISION,
-+ _T(VCS_VERSION), debstr, SPECIALBUILD);
- #else
--const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d (%ls) [debug] %ls")),
-+const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d (%ls) %ls%ls")),
- MAJORVERSION, MINORVERSION,
-- _T(VCS_VERSION), SPECIALBUILD);
-+ _T(VCS_VERSION), debstr, SPECIALBUILD);
- #endif
---
-2.7.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 75beea52acb..8fb7869c349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=pwsafe
pkgname=passwordsafe
-_pkgver=0.98.1
+_pkgver=0.99
pkgver="$_pkgver"BETA
pkgrel=1
pkgdesc="Simple & Secure Password Management"
@@ -14,20 +14,13 @@ depends=('libxtst' 'wxgtk' 'webkitgtk2' 'yubikey-personalization' 'xerces-c')
makedepends=('zip' 'libxt')
optdepends=('xvkbd: virtual-keyboard support')
conflicts=('passwordsafe-debian' 'passwordsafe-git' 'pwsafe' 'pwsafe-gui')
-source=(https://github.com/pwsafe/pwsafe/releases/download/$pkgver/pwsafe-$pkgver-src.tgz{,.sig}
- 0001-Fixed-broken-Linux-Makefile-based-build.patch)
-
-install='passwordsafe.install'
+source=(https://github.com/pwsafe/pwsafe/releases/download/$pkgver/pwsafe-$pkgver-src.tgz{,.sig})
validpgpkeys=('A703C1328EABC7B201753BA3919464515CCF8BB3') #Rony Shapiro
-sha1sums=('505f0d24376ae0dc886958869ea8e2f2e14d85ca'
- 'SKIP'
- '8dcb2d5b9d7f8eb58d7f6b54b23e2a4eaa2b981c')
+sha1sums=('3b736247712c5054e511b8946e7b93eb31eaf287'
+ 'SKIP')
prepare() {
cd "$_pkgname-$pkgver"
- # https://github.com/pwsafe/pwsafe/issues/79
- # git format-patch -1 eea4ef6
- patch -p1 -i ../0001-Fixed-broken-Linux-Makefile-based-build.patch
}
build() {
diff --git a/passwordsafe.install b/passwordsafe.install
deleted file mode 100644
index 408bfe8ffc7..00000000000
--- a/passwordsafe.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- if [[ -x /usr/bin/gtk-update-icon-cache ]]; then
- gtk-update-icon-cache /usr/share/icons/hicolor -q
- fi
-}
-
-post_upgrade() {
- post_install
-}
-post_remove() {
- post_install
-}