summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schnaidt2015-06-08 13:05:54 +0200
committerAlexander Schnaidt2015-06-08 13:05:54 +0200
commitf53d0d5a95b8f0ce0072cbd49bab8e2830344071 (patch)
tree335057e9db9bb3d8ff25561ee392e451d6845d78
parentf82f68bf4aa71521929d6fdd28ea8c7ce9f27414 (diff)
downloadaur-f53d0d5a95b8f0ce0072cbd49bab8e2830344071.tar.gz
passwordsafe-git: update PKGBUILD for wxgtk 3 and changed help-file location
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e847c9ba9dd3..7c68cb30b61c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Alexander Schnaidt <alex.schnaidt@gmail.com>
# Contributor: Brandon Moller <mollerbw@gmail.com>
pkgname=passwordsafe-git
-pkgver=20140506
+pkgver=0.95.1BETA.r78.gec2c244
pkgrel=1
pkgdesc="Simple & Secure Password Management"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/passwordsafe/"
license=('Artistic2.0')
#to build without yubikey support, remove ykpers and uncomment NO_YUBI in build()
-depends=('libxtst' 'wxgtk2.8' 'xerces-c' 'ykpers')
+depends=('libxtst' 'wxgtk' 'xerces-c' 'ykpers')
makedepends=('git' 'zip' 'libxt')
optdepends=('xvkbd: virtual-keyboard support')
conflicts=('passwordsafe-debian' 'passwordsafe' 'pwsafe')
@@ -18,14 +18,14 @@ install=passwordsafe-git.install
pkgver() {
cd "$pkgname"
- git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
- #git describe | sed 's/-/_/g'
+ #git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+ git describe | sed 's/-/.r/; s/-/./'
}
build() {
cd "$pkgname"
# NO_YUBI=1 \
- WX_CONFIG="/usr/bin/wx-config-2.8" \
+ WX_CONFIG="/usr/bin/wx-config" \
make release help I18N
}
@@ -43,7 +43,7 @@ package() {
install -Dm 644 "$doc" "$pkgdir"/usr/share/doc/passwordsafe/"$doc"
done
- install -Dm 644 help/help.zip "$pkgdir"/usr/share/doc/passwordsafe/help/help.zip
+ install -Dm 644 help/helpEN.zip "$pkgdir"/usr/share/doc/passwordsafe/help/helpEN.zip
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
install -Dm 644 docs/pwsafe.1 "$pkgdir"/usr/share/man/man1/pwsafe.1