summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schnaidt2017-09-07 16:48:48 +0200
committerAlexander Schnaidt2017-09-07 16:48:48 +0200
commitf743f1bcb937c91753938f0b9f2e56b8b18c4d69 (patch)
tree9858fb527655df118c035ec31c5c97462ad2c0cc
parent8f7e3043b05fbc9c80c3aec219af9171deb7947c (diff)
downloadaur-f743f1bcb937c91753938f0b9f2e56b8b18c4d69.tar.gz
passwordsafe-git: don't use tags in pkgver(), switch to cmake, add qrencode to deps, add cmake and gtest to makedeps
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD42
2 files changed, 15 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eaa28586346..9a42801fd277 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
# Generated by mksrcinfo v8
-# Thu May 26 06:27:48 UTC 2016
+# Thu Sep 7 14:48:34 UTC 2017
pkgbase = passwordsafe-git
pkgdesc = Simple & Secure Password Management
- pkgver = 0.98.1BETA.r88.g9b1a281
+ pkgver = r11444.80baea965
pkgrel = 1
url = https://pwsafe.org/
arch = i686
arch = x86_64
license = Artistic2.0
makedepends = git
+ makedepends = cmake
+ makedepends = gtest
makedepends = zip
makedepends = libxt
depends = libxtst
depends = wxgtk
- depends = webkitgtk2
+ depends = qrencode
depends = yubikey-personalization
depends = xerces-c
optdepends = xvkbd: virtual-keyboard support
diff --git a/PKGBUILD b/PKGBUILD
index 1d0f7da22cbd..c99af627218d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Alexander Schnaidt <alex.schnaidt@gmail.com>
# Contributor: Brandon Moller <mollerbw@gmail.com>
pkgname=passwordsafe-git
-pkgver=0.98.1BETA.r88.g9b1a281
+pkgver=r11444.80baea965
pkgrel=1
pkgdesc="Simple & Secure Password Management"
arch=('i686' 'x86_64')
url="https://pwsafe.org/"
license=('Artistic2.0')
-#to build without yubikey support, remove yubikey-personalization and uncomment NO_YUBI in build()
-depends=('libxtst' 'wxgtk' 'webkitgtk2' 'yubikey-personalization' 'xerces-c')
-makedepends=('git' 'zip' 'libxt')
+depends=('libxtst' 'wxgtk' 'qrencode' 'yubikey-personalization' 'xerces-c')
+makedepends=('git' 'cmake' 'gtest' 'zip' 'libxt')
optdepends=('xvkbd: virtual-keyboard support')
conflicts=('passwordsafe-debian' 'passwordsafe' 'pwsafe')
source=("$pkgname::git+https://github.com/pwsafe/pwsafe.git")
@@ -17,41 +16,20 @@ md5sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe | sed 's/-/.r/; s/-/./'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "$pkgname"
-# NO_YUBI=1 \
- WX_CONFIG="/usr/bin/wx-config" \
- make release help I18N
+ mkdir -p build && cd build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
- cd "$pkgname"
-
- install -Dm 755 src/ui/wxWidgets/GCCUnicodeRelease/pwsafe \
- "$pkgdir"/usr/bin/pwsafe
- install -Dm 644 install/desktop/fedora-pwsafe.desktop \
- "$pkgdir"/usr/share/applications/pwsafe.desktop
- install -Dm 644 install/graphics/pwsafe.png \
- "$pkgdir"/usr/share/icons/hicolor/48x48/apps/pwsafe.png
+ cd "$pkgname"/build
- for doc in README.txt docs/ReleaseNotes.txt docs/ChangeLog.txt install/copyright; do
- install -Dm 644 "$doc" "$pkgdir"/usr/share/doc/passwordsafe/"$doc"
- done
-
- install -Dm 644 help/helpEN.zip "$pkgdir"/usr/share/doc/passwordsafe/help/helpEN.zip
- install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
- install -Dm 644 docs/pwsafe.1 "$pkgdir"/usr/share/man/man1/pwsafe.1
-
- install -d 755 "$pkgdir"/usr/share/pwsafe/xml
- install -m 644 xml/* "$pkgdir"/usr/share/pwsafe/xml
-
- cd src/ui/wxWidgets/I18N/mos/
- for lang in *; do
- install -Dm 644 "$lang"/LC_MESSAGES/pwsafe.mo \
- "$pkgdir"/usr/share/locale/"$lang"/LC_MESSAGES/pwsafe.mo
- done
+ DESTDIR="$pkgdir" make install
}