summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schnaidt2014-05-10 01:40:33 +0200
committerAlexander Schnaidt2014-05-10 01:40:33 +0200
commitfddeb3b5381a26cb0c3732254171a1f431c716ef (patch)
treeabd54bcc730d27e6a12bb4911cb67a4c9d0e91c9
downloadaur-fddeb3b5381a26cb0c3732254171a1f431c716ef.tar.gz
add passwordsafe-git
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD58
-rw-r--r--passwordsafe-git.install10
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7433585b85d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = passwordsafe-git
+ pkgdesc = Simple & Secure Password Management
+ pkgver = 0.95.1BETA.r78.gec2c244
+ pkgrel = 1
+ url = http://sourceforge.net/projects/passwordsafe/
+ install = passwordsafe-git.install
+ arch = i686
+ arch = x86_64
+ license = Artistic2.0
+ makedepends = git
+ makedepends = zip
+ makedepends = libxt
+ depends = libxtst
+ depends = wxgtk
+ depends = webkitgtk2
+ depends = ykpers
+ depends = xerces-c
+ optdepends = xvkbd: virtual-keyboard support
+ conflicts = passwordsafe-debian
+ conflicts = passwordsafe
+ conflicts = pwsafe
+ source = passwordsafe-git::git://git.code.sf.net/p/passwordsafe/git-code
+ md5sums = SKIP
+
+pkgname = passwordsafe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bffa16aabba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Alexander Schnaidt <alex.schnaidt@gmail.com>
+# Contributor: Brandon Moller <mollerbw@gmail.com>
+pkgname=passwordsafe-git
+pkgver=20140506
+pkgrel=1
+pkgdesc="Simple & Secure Password Management"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/passwordsafe/"
+license=('Artistic2.0')
+#to build without yubikey support, remove ykpers and uncomment NO_YUBI in build()
+depends=('libxtst' 'wxgtk2.8' 'xerces-c') #'ykpers')
+makedepends=('git' 'zip' 'libxt')
+optdepends=('xvkbd: virtual-keyboard support')
+conflicts=('passwordsafe-debian' 'passwordsafe' 'pwsafe')
+source=("${pkgname}::git://git.code.sf.net/p/passwordsafe/git-code")
+md5sums=('SKIP')
+install=passwordsafe.install
+
+pkgver() {
+ cd "$pkgname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+ #git describe | sed 's/-/_/g'
+}
+
+build() {
+ cd "$pkgname"
+ NO_YUBI=1 \
+ WX_CONFIG="/usr/bin/wx-config-2.8" \
+ make release help I18N
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm 755 src/ui/wxWidgets/GCCUnicodeRelease/pwsafe \
+ "$pkgdir"/usr/bin/pwsafe
+ install -Dm 644 install/desktop/fedora-pwsafe.desktop \
+ "$pkgdir"/usr/share/applications/pwsafe.desktop
+ install -Dm 644 install/graphics/pwsafe.png \
+ "$pkgdir"/usr/share/icons/hicolor/48x48/apps/pwsafe.png
+
+ for doc in README.txt docs/ReleaseNotes.txt docs/ChangeLog.txt install/copyright; do
+ install -Dm 644 "$doc" "$pkgdir"/usr/share/doc/passwordsafe/"$doc"
+ done
+
+ install -Dm 644 help/help.zip "$pkgdir"/usr/share/doc/passwordsafe/help/help.zip
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm 644 docs/pwsafe.1 "$pkgdir"/usr/share/man/man1/pwsafe.1
+
+ install -d 755 "$pkgdir"/usr/share/pwsafe/xml
+ install -m 644 xml/* "$pkgdir"/usr/share/pwsafe/xml
+
+ cd src/ui/wxWidgets/I18N/mos/
+ for lang in *; do
+ install -Dm 644 "$lang"/LC_MESSAGES/pwsafe.mo \
+ "$pkgdir"/usr/share/locale/"$lang"/LC_MESSAGES/pwsafe.mo
+ done
+}
diff --git a/passwordsafe-git.install b/passwordsafe-git.install
new file mode 100644
index 000000000000..a438c6682fd8
--- /dev/null
+++ b/passwordsafe-git.install
@@ -0,0 +1,10 @@
+post_install() {
+ gtk-update-icon-cache &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}