summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Klinkovský2020-12-21 14:05:52 +0100
committerJakub Klinkovský2020-12-21 14:05:52 +0100
commit7bbe3e2908993d66acf218314d7d00bb88670bcd (patch)
tree27f8f657ddcd63c022c6d11af00a549bfe97cb0b
parentd33f055862e99d65a6ede71915067d8e47c6a98b (diff)
downloadaur-7bbe3e2908993d66acf218314d7d00bb88670bcd.tar.gz
Updated to 6.1.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD63
-rw-r--r--coeftabMemory.patch11
3 files changed, 70 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 078e4e880afe..ae143a89bf71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,31 @@
-# Generated by mksrcinfo v8
-# Thu Aug 16 02:11:40 UTC 2018
pkgbase = pastix
- pkgdesc = high performance parallel solver for very large sparse linear systems based on direct methods
- pkgver = 6.0.1
+ pkgdesc = High performance parallel solver for very large sparse linear systems based on direct methods
+ pkgver = 6.1.0
pkgrel = 1
url = https://gitlab.inria.fr/solverstack/pastix
arch = x86_64
license = CeCILL-C
makedepends = gcc-fortran
makedepends = cmake
+ makedepends = git
+ makedepends = doxygen
depends = cblas
depends = lapacke
- depends = scotch
depends = hwloc
- source = pastix::git+https://gitlab.inria.fr/solverstack/pastix.git#tag=6.0.1
+ depends = scotch
+ depends = metis
+ depends = openmpi
+ depends = python
+ provides = libpastix.so
+ provides = libpastix_kernels.so
+ provides = libspm.so
+ provides = libspmf.so
+ source = pastix::git+https://gitlab.inria.fr/solverstack/pastix.git#tag=v6.1.0
+ source = gitmodules.diff
+ source = coeftabMemory.patch
md5sums = SKIP
+ md5sums = 59430d563cc9a665292c0d793520e148
+ md5sums = 75c21a70d036c8f50ac5a5ffb8f827bb
pkgname = pastix
diff --git a/PKGBUILD b/PKGBUILD
index bf0c5ceebbcf..d0f5951d0684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,59 @@
-# Maintainer: Myles English <myles at tdma dot co>
+# Maintainer: Jakub Klinkovský <j.l.k cat gmx dog com>
+# Contributor: Myles English <myles at tdma dot co>
+
pkgname=pastix
-pkgver=6.0.1
+pkgver=6.1.0
pkgrel=1
-pkgdesc="high performance parallel solver for very large sparse linear systems based on direct methods"
+pkgdesc="High performance parallel solver for very large sparse linear systems based on direct methods"
arch=('x86_64')
url="https://gitlab.inria.fr/solverstack/pastix"
license=('CeCILL-C')
-#depends=('python2' 'openmpi')
-depends=('cblas' 'lapacke' 'scotch' 'hwloc')
-makedepends=('gcc-fortran' 'cmake')
-#optdepends=('metis' 'parmetis')
-#conflicts=("pastix-git")
-source=("${pkgname}::git+${url}.git#tag=${pkgver}")
-md5sums=("SKIP")
+depends=('cblas' 'lapacke' 'hwloc' 'scotch' 'metis' 'openmpi' 'python')
+makedepends=('gcc-fortran' 'cmake' 'git' 'doxygen')
+provides=('libpastix.so' 'libpastix_kernels.so'
+ # also provide the SpM library (internal module)
+ 'libspm.so' 'libspmf.so')
+source=("${pkgname}::git+${url}.git#tag=v${pkgver}"
+ gitmodules.diff
+ coeftabMemory.patch)
+md5sums=('SKIP'
+ '59430d563cc9a665292c0d793520e148'
+ '75c21a70d036c8f50ac5a5ffb8f827bb')
prepare() {
- cd ${pkgname}
- patch -p2 <../../gitmodules.diff
- /usr/bin/git submodule update --init --recursive
-}
+ cd "${pkgname}"
+ patch -p2 < ../gitmodules.diff
+ git submodule update --init --recursive
+
+ # fix compiler error due to coeftabMemory
+ patch -Np1 < ../coeftabMemory.patch
-build() {
- cd "${srcdir}/${pkgname}"
[ -d build ] && rm -rf build
mkdir build
- cd build
+}
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DPASTIX_INT64=OFF
+build() {
+ cd "${pkgname}/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_DOCUMENTATION=ON \
+ -DPASTIX_ORDERING_METIS=ON \
+ -DPASTIX_WITH_MPI=ON \
+ -DPASTIX_INT64=OFF # because scotch is not compiled with int64
make
}
package() {
- cd "${srcdir}/${pkgname}/build"
+ cd "${pkgname}/build"
make install DESTDIR="${pkgdir}"
- install -Dm644 "${pkgdir}/usr/examples" "${pkgdir}/usr/share/doc/pastix/examples" && \
- rm -rf "${pkgdir}/usr/examples"
+
+ # remove the env script (not necessary since we install into /usr which is searched by default)
+ rm "${pkgdir}/usr/bin/pastix_env.sh"
+ rmdir "${pkgdir}/usr/bin"
+
+ # move examples into proper doc directory
+ install -dm755 "${pkgdir}/usr/share/doc/pastix/"
+ mv "${pkgdir}/usr/examples" "${pkgdir}/usr/share/doc/pastix/"
}
diff --git a/coeftabMemory.patch b/coeftabMemory.patch
new file mode 100644
index 000000000000..8dea327eace6
--- /dev/null
+++ b/coeftabMemory.patch
@@ -0,0 +1,11 @@
+--- a/sopalin/coeftab.h 2020-12-21 13:30:01.752576973 +0100
++++ b/sopalin/coeftab.h 2020-12-21 13:41:00.673558640 +0100
+@@ -53,7 +53,7 @@
+ /**
+ * @brief List of functions to compute the memory gain in low-rank per precision.
+ */
+-coeftab_fct_memory_t coeftabMemory[4];
++extern coeftab_fct_memory_t coeftabMemory[4];
+
+ /**
+ * @}